Issues with IF Assistant & IF Pax

Hello guys,

IDK whether this topic have been spoken or not, here is the thing.

When I fly for long time and leave my device for a while, then I come back to start landing procedure,
somehow the app ( IFassistant and IF pax) doesnt work, like… if I turn spoiler up the co-pilot doesn’t speak and I have to close the app and reopen it again… same as IF pax. It is annoying.

Thank you
Using iPad 2017

Sorry again if this topic have been created
Allen Lu

1 Like

Restart device. Try that.

Hi, I don’t think this is the issue, bc is about the background activity.
btw am using iOS

Make sure you have 1GB of RAM and you restart your device on a regular basis. That should fix the issue.

You’re not locking the iPad or changing apps in between are you? IF stays fully on at all times?

1 Like

Hi!
Yes, just stay on the screen… didn’t lock the ipad and changing app

When I did a 14hrs flight, it happened too, both app stopped. On my recent almost 10hr flight, I ran solely IF Assistant and came back occasionally to do my step climb every few hrs, I find that IF Assistant was still active.

Not sure what caused it to deactivate, perhaps the lack of input? I was going to try another 14hrs with my continuous presence in the next few days.

2 Likes

I see…
yeah it is just like… if u don’t use it for a while… then those apps seem will be go in sleeping mode…kind of like this.
But yeah the issue does exist.

1 Like

Happened to me aswell

2 Likes

Its best to speak to @epaga and Mr @Luqman_Hussain about this ;).

1 Like

The app would deactivate when

  1. You received a call / You are calling someone mid-flight.
  2. When you set an alarm and it goes off mid-flight (which will most likely cause IF to crash anyways)
  3. When the audio output changes mid-flight. (Headphones to Bluetooth speakers, iPhone speakers to Headphones etc)

I’m not sure about locking the device would cause IF Assistant to stop working, but what I’m sure is changing apps during flight won’t cause IF Assistant to stop working (I’ve tried it before)

When using IF Assistant for quite a while now, this is what I’ve uncovered (I’m running an iPhone 7). So far, there’s no solution to this other than restarting IF Assistant while your flight is still running. This may be caused due to the limitations of a background app running on a phone.

Cheers

2 Likes

well I didn’t do anything just leave the device there, after like an hour came back for start landing procedure then just didn’t response :/

Thank u

Exit both Apps and close them then reopen it, I think that’ll work.

1 Like

haha obviously…
that’s why is annoying, u have to reopen it again as landing procedure is kinda busy…
just waste of time :D

Meh, doesn’t take much time. Better than nothing! :D.

1 Like

Thanks everyone for all your help!
I would add:

Make sure the power saving mode is off on your phone, because that will deactivate any background apps.

Also if your device is not that strong, you can try turning down the graphics a little bit in the infinite flight settings, I know that helped one person.

Hope that helps!

Hi thanks for replying.
No I did not use battery save mode, and my iPad surely can run all graphics in high…

So will be appreciative if you guys can fix this minor bug.

Merci

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.