Issue with App Crashing

Hey Guys,

I hope someone can help me out. I’ve been having issues with the app crashing over the past week. It doesn’t do it on every flight, but about half or so. As you can see from the screen shots below, it happens sometimes only a few minutes into the flight and other times just as I’m on approach. Obviously, this is frustrating since I’m putting in the time and I don’t get credit for a landing.

I’ve been running Infinite Flight on the same 12.9” iPad Pro for about 6 months and the previous model for two years before that. This week is the first time I’ve had this issue. I’ve got plenty of storage memory available and this is the only app that crashes. I’ve tried clearing my cache and deleting the app and reinstalling.

Any ideas?


Have you updated to iOS 11.4 yet? I recently updated my iOS because of this same issue and haven’t had any problems since.

I took another look after your screenshots loaded and noticed you are still on 11.3, I would try updating and try to reproduce.

5 Likes

I have not but I will try that. Thanks for the suggestion.

1 Like

Just another thing that I forgot to mention. Be sure to restart your device in between flights if you can.

3 Likes

If you do all of that and there is still no difference then I would try utilising limit frame rate. It’s not ideal for such a new device but I personally find it helps keep the app running smoothly on my Pro.

1 Like