Is Global compatible with my device?

so when I read the post earlier it suggested that global will be available to anyone even if they don’t have 3.0 and have 2.0 for example as it implied that they’ll raise there future requirements. but for now it’s fine . but I’ve got no updates available . the actual page however has updated? so do I be patient or do I need to buy a kindle or something with 3.0 ? . thanks :)

Thank you for contacting support!

Our minimum device requirements have recently changed due to the rapidly evolving features of Infinite Flight which require greater device performance and specifications to smoothly operate. To ensure the best possible experience we recommend that a device has at least 1GB+ of internal device memory (RAM). Our mission will be to continually optimize performance, however the bar must be raised with future features in mind.


iOS Requirements:

  • 64 bit device
  • iOS 10 operating system or later
  • Click here to see full list of iOS devices supported at this time

Android Requirements:

  • Android 5.0 (Lollipop) operating system or later
  • Device must support OpenGL ES 3.0

Note: Due to large variety of Android devices there is not a specific list of supported devices. Customers with devices that are not supported at this time will receive a message on the Google PlayStore when attempting to download the latest update for Infinite Flight to advise that the device in use is not supported.


We appreciate your understanding and apologize for any inconvenience.

5 Likes

You need OpenGLES 3.0 to get te update unfortunately!

1 Like

Thank you for contacting support! Unfortunately this update will not be released for Amazon devices. We will gauge Amazon demand at a later date to determine whether or not we will continue to support the Amazon App Store updates. We apologize for any inconvenience.