IOS app keeps quitting

Hello, I don’t know if this is a problem some of you have, but I have tried to do 3 flights, where the app has quitted middair although I have a new and powerful device. Maybe it is IF assistant and IF operations? No idea but quite frustrated. Please help!

What device are you on?

Have you tried without the other apps running?

Do you have low power mode and limit frame rate enabled?

2 Likes

Hey Chris! I am on an iPad air 2 and I’ve also tried without the other apps. I am currently trying to do a flight. Let’s see what happens.

Cheers mate!

Hello for the Air 2 you must have limit frame rate on during long hauls or you will experience app crashing. Also low power mode is helpful to avoid having your device heat up and crash.

Just to note this is the device that is also use and mine has only crashed once or twice over the past year.

Ok, I noticed I did not have low power on. I will do so. Thanks!

1 Like

It’s certainly odd I must say. I have max settings on along with those apps you listed and I never have any issues so I will do my best to assist you, let me know how you get on over the next few flights you do and if it still crashes at that point then it’s best to look into some alternative solutions.

One more thing to note, once at cruise turn your brightness all the way down, this will conserve battery also and hopefully reduce the heat your device builds up.

Thank you! It is in fact quite odd. I don’t remember when was the last time it crashed and all of a sudden it happened again. For now I am arriving at Cruise level and all good for me. Let’s see what happens when I start approaching.

1 Like

I am having the exact same issue with the IPad 2018 Generation. @Jeronimo_Castro Did you only just recently install the most recent IOS update? It only started happening for me after installing the latest IOS update.

I also noticed a correalation that the flight would exit the app after around 2 hours and 30/50 minutes. I too and still trying to decipher the issue and have edited a few of my settings including switching anti-aliasing off and will give it another go now.

2 Likes

I am following these cases for a couple of weeks now. It seems that the iOS 12.1.2 update caused similar issues on iPhones. For iPads I couldn’t make a conclusion as I only managed to update our ipad mini 2 to 12.1.1.

It has also been reported that app quitting happens during long hauls when the direction of flight is West to East, as well as the issues seems to be solved by installing iOS 12.1.3 and above.

My test flight for iver 10 (if not more) separate occasions was the EGLL-YSSY route. Never managed to get over 3 hours of flight time. Funny, as doing it in reverse I went over 5.5 hours (when I manually quit the app).

Android is not relevant, but has the same issue for those who installed the December 2018 security patch. I have just received the January 2019 update so I’ll carry on with more test to see whether it has now been sorted or not.

This definitely seems to be a non-IF but OS related issue based on the information I currently have from my own tests and reports I’ve received from other forum members here!

3 Likes

Right, thanks for that. And is that Apple update you speak of currently available?

I just came back from another attempt (number 4) and it exited after 2 hours and 50 minutes. I was going West to East, however this still shouldn’t be happening.

I also already tried:

  • reinstalling app.
  • fully turning off iPad.
  • editing settings.

Edit: I just checked and I already have IOS 12.1.4.

3 Likes

According to this, 12.1.4 is already out.

@schyllberg has already been made aware of this thorough several other topics kand by me 😂) throughout the last couple of weeks and we have gathered loads of information but it’s still not quite enough to conclude the case just yet.

I’ve provided a log file via beta and I will try try to reproduce the issue on android with the January security patch installed tomorrow (as I’m out for a family gathering all day today).

If you update your OS and do further tests, please make sure to report back if the issue is still persists or not so we can square this off once and for all on iOS and also to make us able to provide adequate support for other users as well.

Alright, appreciate the help. Strange that for me it’s only happening since updating to 12.1.4 but never before that. I’ll take a dive into my actual iPad settings to see what I might be able to do to fix it.

1 Like

I’ll test it with going from East to West like you say to see if this produces any issues or not. @The_Wolf

1 Like

Your case makes it even more interesting as previous reports suggested the issue to be solved by installing 12.1.3.
West to East, EGLL-YSSY provided the same result: app quits before reaching 3 hours flight time. This seems not to be a crash as there’s no crash pop-up (at least on android), but more like someone pressed the home button.
East to West, YSSY-EGLL was fine until around 5.5 hours when I manually ended the flight as I’ve had no time to fully finish it!

Also, if you can do another West to East flight, have a look between 2.5 and 3 hours on the map for your location. If we stick to the EGLL-YSSY route-wise, we both could have roughly the same results…

1 Like

I am currently flying an westerly flight out of LFPG on casual and have been flying for around 5 hours now, so eastern flights definitely work.

1 Like

You flying west without issues and this makes eastern flighst work? 😊 I think I get it, but it’s confusing. Don’t edit please otherwise my comment won’t make any sense! 😂

1 Like

Oh gosh… that’s a really terrible mistake. You know what I mean!

1 Like

No idea. IOS 12.1.4 came out. I installed it and was doing a rather short SKSP-SKBO which is around 1 h 45 min 650nm flight. I was climbing up to FL390 on an a321. It was on autopilot and low power Mode. Again, I was not using any kind of app other than IF assistant and IF operations. I was just monitoring the climb, when at around FL320. It crashed again. Please help!

Hey!

First off, what graphics settings are you on?
Have you tried to do any of these flights without running IF Operations and IF-A at the same time? If so, what’s the result?