iOS 10.3.3 Global Update

Hello, My device is running IOS version 10.3.3 and i have the global update available, however when i go to update the app, it says “the update requires version 10.3.3 or higher” ???
Any thoughts?

1 Like