Infinite flight won't load

When I open infinite flight it goes to the screen with the logo and stays there/ freezes there
Device specs:
Latest Infinite flight
iOS 10.3.1
iPad Air 2 16 gb

Have you tried re-installing the Infinite Flight? Restarted your iPad?

2 Likes

ok give me a few minutes.

Tried both still won’t work.

You probably need to factory reset your iPad then. There’s not much to be done besides that i’m afraid.

2 Likes

I tried factory resetting it before and I had to get a new iPad so I guess no more IF.

Are you sure you’re not being patient enough? Open Infinite Flight and wait (at least) 3 minutes and see where you are. It’s worth the shot.

1 Like

That should not be the case! As you’re well aware, there are several users currently using the same device as you and having Infinite Flight on their device without any problems.

Have it worked before on this specific iPad?
If so, have anything changed between when it worked up until now when it does not?
I also noticed you’re running iOS 10.3.1, even though the current iOS build is 10.3.2. Any reasons for that?

2 Likes

Nothing has changed I opened infinite flight this morning and it ran fine but I opened it an hour ago and didn’t run at all

I have to do the occasional hard reset on mine Daniel but that’s because I use mine for work (AutoDesk BIM 360, Procore etc…) Follow the procedures provided:

2 Likes

I have done this before

Update your software to the latest iOS. I don’t understand the reason not to do this. Try after that

6 Likes

Ok all be back after I install it

Latest iOS taking a while to download be back when it’s done. I’m on my phone now

Okay try and load Infinite Flight and get back to us with the results

1 Like

It worked! Finally! Thank you everybody for your help!

3 Likes

That’s great to hear. Have fun!

1 Like

Thanks to @Chatta290! (Can’t believe it worked, lol)