Infinite flight stuck on loading screen after download

Device: ASUS ROG Phone 7
Operating system: Android

For some reason, infinite flight is stuck on the loading screen, then after a while it says error code 8. I have a good Internet connection and have tried redownloading and restarting my device but it hasn’t worked.

Welcome to the community! Error code 8 means that Infinite Flight is not able to communicate with your network. You can try doing a hard reset on your device but you may need to try changing wifi networks or try toggling cellular. This is usually something that is not directly Infinite Flight related but more device/network related. Has there been any changes to your network, etc? Even something as simple as firewall rules can have an impact.


Looking at your profile, it seems that you’re connected via PLDT (Philippine Long Distance Telephone).
Unfortunately there’s an ongoing issue between them and our content delivery network that we’re pursuing that’s probably the cause of your issue.

We’re doing our best to push here but haven’t been much successful yet, but we just now pushed again hoping for some results.

Sorry about the inconvenience!


No, there haven’t been any changes to my internet, although ever since I logged in to my brother’s Google account, Infinite flight hasn’t been working, and the issue I stated above happened.

Oh, ok, thanks for the reply.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.