Infinite Flight not loading

Infinite Flight on my iPad won't open, it's stuck on the logo. I tried uninstalling it and re-installing it and yet still stays on the logo when I try to open in

Have you tried restarting your device? I’m not having this app issue.

Sometimes for me it says there error so I delete the page then get back on it and it works

Try to make sure you’ve cleared all of your open tabs, as IF tends to take up a lot of memory (RAM).

Also, ensure you have an internet connection, as this may stop the app from loading (although it does tend to tell you if you are lacking one)

1 Like

I have yes

yeah i did that too

1 Like

How long have you left it to load? I’d say leave it at least a few minutes, which is longer than it sounds when you’re looking at a watch ;)

If not, I’m out of ideas :(

1 Like

alright thanks

i’ll try it

1 Like

Try freeing up some storage space.

1 Like

still nothing at over 30 minutes, just says infinite flight cannot connect to server or something

I’m which case that’s most likely down to your internet connection.

Ensure you have a good WiFi connection, and try to get closer to the router (assuming you have one).

Turn off any VPNs as well, as these can sometimes affect the connection.

1 Like

alright i’ll try that

1 Like

Hello @Greenland3690!

Sorry about your troubles. I have had this issue aswell and I believe I have a fix for you but I need more information.

  • Are you connected to internet
  • If so make sure it is secure and strong or doesnt have IF blocked like school wifi. Try switching wifi or resetting the router if your home. If away try with Cellular data.

Hope this helps!

-Blake

1 Like

I have had this problem and I have solved it after weeks of support and trying to figure it out.
Here is a Step by Step of what I did to help:

1: Restart device
If doesn’t work try
2: Go to settings screen shot or memorize all your personalized settings; then Uninstall then reinstall
If doesn’t work try
3: Close app, then open on Cellular data then if it works load into flight then turn WiFi back on
If doesn’t work try
4: disconnected from all VPN and try again with restart and using wifi then Cellular only
If doesn’t work try
5: uninstall and wait an hour then reinstall

Hope this helps :) I had this problem Fall 2020… IPad Air 2 2017 or 2018

1 Like

Also, none of these worked. Then one day it worked. Another day stopped working, and now it works without a problem.
It’s weird

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.