Infinite Flight Likes to Crash

While I’m sure we’re all enjoying the new update (I am too, don’t get me wrong-- love the look of the GSE equipment on regional jets), I’ve been noticing a huge problem when flying my longer, 12+ hour flights: either on approach, or final, Infinite Flight has crashed on 9 out of the last 10 flights I have conducted, all within late May or early June. I don’t need to touch or even look at my tablet for this to happen.

Any ideas why, what I can do, or if there are attempts being made to fix this? I use a newer iPad and have software and Infinite Flight updated as much as possible. And, from what I’ve heard from friends, this is an issue for many.

JSC Aviation

1 Like


Could you provide your device and its operating system version? Just so that when someone else answers they have the information.

Safe Travels,


iPad Pro on 15.5


First and foremost, make sure you have a fast and reliable internet connection at all times when playing Infinite Flight. This may be one of the reasons your app is crashing.

Other than that, have you tried uninstalling and reinstalling IF? Sometimes this helps. If that doesn’t work, clear your caches in IF settings, including your scenery cache.

I am not a member of technical support, and I hope that if my solutions do not assist that they reach you separately to discuss your problem.

Safe Travels,


Hey There,

Thanks for bringing this up. I coincidentally have also not completed one approach as well without a crash. However, I am in contact with some of the staff team regarding this issue.

I personally have tried all the methods I am aware of, and I will list them here for you to try as well:

  1. Clear scenery cache

  2. Lower graphics settings (my iPhone 11 Pro Max can handle any settings however I did it for the sake of experimenting and I didn’t see a problem here for users with this device)

  3. Delete application and redownload the application.

  4. Check your storage settings on your device.

  5. Check your wifi settings as well as cellular data connection.

Note: I am currently running the IOS 16 Developer Beta, and I clarified with @schyllberg this is not likely a possible issue for other IOS users that might be experiencing this.

From what had been brought to my attention after I looked into this, the team on there end does not see any discrepancies. However, that does not mean nor eliminate the possibility of this might being a bug (meaning they are going to keep there eyes on it if it becomes persistent).

Feel free to shoot me a PM if you need any more assistance, or have any queries. :)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.