Infinite Flight keeps crashing

Hello IFC at the moment I’m experiencing a big problem on My IPhone 7 running IOS 12.31. The problem is Infinite Flight when I open it up it loads the Infinite Flight logo (Which is damn sexy 😘) but the app crashes and keeps exiting out not even getting me to the loading screen.

Some Information: I’ve recently moved from my old house which had what is called Fibre which is like super fast internet to a new internet source I’m not sure if this’ll have anything to effect it but I thought it may help.

Thanks in advance for everything in advanced and sorry if this is something that’s already been said


I suggest you read this and inform us about what you have done to solve the issue.
Good luck!

You see the problem is that I can’t physically get into the app I’ve even restarted my phone

Have you reinstalled the app?

1 Like

Have you tested IF on a mobile network? Same result?

I’ll test it on my mobile data and see

1 Like

So update it’s still crashing out

Did you do a soft restart/reset of your phone, or just turned it off/on?
And you reinstalled IF as Hamza mentioned?

I’ll try reinstalling it

1 Like

Have you clear you’re scenery?

Can we please get this mentality that the Clear Scenery cache button is some magic button that solves every problem?! He can’t even get into the app its self, so I’m curious as to how he can clear the cache. This might also come as a shocker, but the scenery cache button is only for the purpose of scenery. The scenery cache only deals with the scenery people, nothing more, nothing less. It’s not the aircraft cache, the autopilot cache, the device shutdown cache or live server cache.

@Lovethisgame, can you tell us how much available storage you have?

1 Like

He can’t get into the app to clear the cache. A bit of a pickle, but deffidently reinstall the app for this problem

You could also try to restart your phone, that used usually works for me.

Have you tried factory reset that must work.

Doesnt that erase all the data on my phone

1 Like

Before doing a factory reset can you do a speed test of your internet connection?

Also; Try another WiFi network if able.

It must be my phone because my IPad mini can open the app and work it

1 Like

Problem Is Now Fixed Thank You All For Your Help. See You in the Bright Sky

1 Like