Infinite Flight is not showing up or connecting to ForeFlight devices

To November 15, 2021 I’m having a lot of trouble marrying Infinite Flight to ForeFlight. I run infinite flight on one iPad in for Foreflight on another iPad and both iPads are connected to the same Wi-Fi network. I feel like I have done everything there is to do and took all day researching this problem and I’m still not able to figure out why infinite flight doesn’t show up in the devices that’s in ForeFlight. I have enabled disabled enabled disabled, restarted the Infinite Flight app, and restarted Foreflight having the Location settings set on while using the app option. Still nothing, so I’ve uninstalled both apps and reinstalled and also reset Network settings on both iPads. Both of my iPads are running the latest iOS and I am still not able to run for flight with Infinite Flight. Sometimes it helps in the past when I spawn into a airport and if the location does not move on ForeFlight than I will restart the iPad that infinite flight is on and the problem will be fixed meaning the location dot on the ForeFlight map will finally move from my real location to the airport I spawn at. But now it doesn’t work and I tried everything else, so can someone please help me and have any suggestions or know something I don’t or maybe missing to solve this problem?


I suggest you to post this topic on #support :)

Would be more helpful !


I recommend checking this topic that I’ve linked below for updates on the issue you are currently experiencing:

As mentioned by Cameron, they have isolated and fixed the issue and have sent off the hotfix for Apple and Android to be released.

Android hotfix is now available on the Google Play Store (21.06.03).

Fingers crossed this solves the issue you are experiencing very soon!

As above!