Infinite Flight is broken

My Infinite Flight is broken, I don’t now what happened exactly but once I try to take off from any airport the aircraft goes to the left and then crash. Even I got a violation for “maneuvers” and I wasn’t. I kept the replays and need to take that violation away.

Hey!

  • Is there any sort of wind/crosswind when you takeoff?
  • Did you start all engines before applying thrust?
  • Is your fuel symmetrical?
  • Is your autopilot on?
  • Did you calibrate?

If answer is no to all these questions, try restarting the game. If it still doesn’t work after retrying with the questions above, try restarting your device, and if it doesn’t work again try reinstalling the app, maybe some files got corrupted when updating to 23.2.

My answer to all of them is “no” everything was okay and working. What about the violation? I still have the replay and I wasn’t trying to do maneuvers, just trying fly tonight and this happened.

Try sending a PM to appeals, but they will remove the level 1 violation only if it is really a game bug.

I think I know what was the problem. In the last update Infinite Flight didn’t allow me rotate my screen, but in this new update the game finally allowed. So I did active that option and my game got calibrated but it went to the left.

Is it a bug game? I think it’s, I did everything under the rules.

Can you share the replay using sharemyIF:

It could give us a better insight into what happend.

May you assist me?

If you can share your replay I will try my best :)

Sure, sharing…

1 Like

I already shared the replay, hope you can fix the problem and take the violation away.

You need to share a link for me to see it. :)

I can’t do that, please PM @appeals with the replay. I’m just trying to help find the cause of the problem.

It looks like they are only removing violation level 2 and 3

Yep, but as mentioned above if the violation was given due to a game bug, it can be removed. Have you contacted them yet?

Never, I just did.

All of my past violations were for bad practice, excepting the new one.

edit (on what I said below): I’m now getting an uncontrollable bank to the left after testing that. So I don’t know what’s causing it.

I noticed the screen rotation while starting IF which I don’t recall from before.

And I also now see that it occurs during flight.

But I don’t see how it’s likely to interfere with you going to one side.

If I try the screen rotation during flight I have to rotate my device at a large angle, and I would only try that when AP is set because otherwise I start banking immediately.

So I can’t right off see a way it might interfere with control.

1 Like

I contacted the appeals team, they checked my replay and the violation was removed. However it’d be cool if this issue doesn’t happen again, I don’t know how it could affect my controls but it did, and I’m absolutely sure since I blocked the screen rotation and it kept working well but once I turned off again the issue came back.

2 Likes

I’m happy to hear it worked out for you.

I might as well just report what I’m seeing. I was testing the screen rotation effects in solo mode. I was rotating my device to large angles to examine screen rotation in combination with AP being both on and off.

I had full control at first: I could remove the large, induced bank angle and any pitch issue, with the usual control input motions.

But now although I have pitch control, I have no bank control and a strong banking tendency that does not at all respond to me rotating my device. The lack of bank control continues to exist no matter how many times I reset using the “final” function, and even though I re-calibrate.

I went to “controls” and full roll response is being shown, but again returning to flight there is no roll control, and a strong bias to bank to one side.

This is just an info report. I assume when I leave the session and fly, it will be corrected.

2 Likes

Hey there, please make sure to always calibrate, check the airport weather in case of any gusts crosswinds or possible rudder disfunction. Then you can also try and restart sour device in case of a rudder error

Thanks for reaching out
Charles

I haven’t done any android OS update since installing the new IF, but the rotation only just started with the new IF update. So, I’m not sure what that means. I don’t think I’ve changed anything else. I might go back and see what I can see. The roll “lockout” only happened that one time so far.