Infinite Flight Crashing on replay

As I was just about to do some filming, I was loading a old replay and Infinite Flight crashed after loading at 100%, I’ve already restarted my IPad and reinstalled Infinite Flight, the problem persists, I have space on the iPad, It’s weird because some work and others don’t, I’m guessing it’s my iPad getting old?

Device: IPad 9.7 2018

1 Like

I’m pretty sure I have that same iPad. It’s most likely the amount of RAM on your device. It could also be the size of the replay. Longer flights have longer replays, and it takes up a lot of space. Let me know if this helps!

EDIT: I also have had some crashing issues in the past. I deleted unused apps on my iPad, restarted it, and it seemed to be fixed.

It could be the RAM, it seems to crash on a 11 minute flight too.

I see. Do you have good internet connection? Also, try to close out all apps in the background.

Internet connection is fine, background apps were also previously closed.

Hmmm… I’m pretty sure you can download the replays (correct me if I’m wrong). Once doing that, you should be able to view it.

If it doesn’t work, then its most definitely your RAM. Either that, or some issue that I can’t think of or I don’t know about.

The replays are saved onto the files app, when clicking them, it takes me to Infinite Flight and imports successfully (normal procedure), I then click replay, seconds after saying 100%, it crashes, I don’t know if that’s what you meant with “downloading”.

Oh, I meant by saving them to photos. I have to go for 30 minutes for a piano lesson. I’ll try to help you after.

Alright. I’m back. Did the save to photos work?

Welcome back, I can’t find any options on saving them to photos, would you mind enlighten me on how you do that?

1 Like

Yes, let me try. Give me 15 minutes max.

I think he talk about downloading replay;
Download your replay with


-After downloading On your Device
-delete the replay on IF.
-Then re-upload it on IF.
-If it didn’t work try contact a mod

Just tried doing that with a replay, the problem still persists.

1 Like

Ok. So I just tried it and it didn’t work, Since most of the things we tired didn’t work, it’s highly likely it’s your RAM. Sorry we couldn’t figure it out!

Ok contact one of these
@Chris_S
@schyllberg
They will help you !

Or do what @GPilot118 suggested!

I have an IPhone XS from 2018 and it still work, think is the iPad the problem.

Or wait try to put you graphic to low it’s gonna work (hope) ?

Thank you for trying to help.

Thank you for also trying to help, will do that.

I have already tried, problem still persists.