Infinite Flight crashing after clicking on "I aleardy have an account button"

Hello everyone, when I click on the “I already have an account” then on “sign up with Google”, it shows the load and it crash, what are the solutions please. 😯

Tried rebooting device but it doesn’t works.


Do you have an account with us, linked to Google since before?


Yes, I created an IF account with Google.


What is the callsign & display name for that account?


Display name: IFC - Alex Kraz 2
Callsign: I didn’t remember the Callsign.

1 Like

Gmail address ending with 4945?


Yes, it is.

1 Like

Ok, good. Just wanted to make sure of that first.

I would begin with restarting your device first. Just so we cover all of the basics before doing anything drastic.


I uninstall and reinstall the simulator: didn’t work
I restarted the device: didn’t work

It continues crashing.

Do you ever get to the point where you sign in?

I think yes.

But It continues crashing after clicking on “I already have an account”, “sign up with Google”, show the load screen, and crash.

ive had this problem before. do you have in app purchases enabled on your phone?

I think yes, but I didn’t buyed an IF subscription.

If you havent bought a subscription thats probably why.

Hello everyone, I finally founded this problem:
It’s because I haved an old version of Chrome probably the 2015 version, because I have an Android 5.0.2, when I updated Chrome, it worked and I logged normally to my IF account. 😊


oh perfect, glad you figured it out :)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.