In-Flight Assistant - Bring your Infinite Flight experience to a new level! V-Speeds, GPWS, PA, and more!

dont know about everyone else, but IFA is working beautifully since what I believe was the last pushed fix. @epaga take a stab at getting a fix for IFops now?

Unfortunately at the moment there are no plans for updating IF-O.

Great to hear, @VirgilMapleYN!!


In other news, Infinite Flight is asking which third party tools you guys use - please let them know you use In-Flight Assistant! 👍🏻 https://twitter.com/infiniteflight/status/1704130188668518484 I really hope they keep supporting third party apps!

2 Likes

Just came back to IF. Is IF-A supposed to be working now? I quickly read about the new API causing problems a few months ago but according to recent comments in this thread it should be working. However, the app does not work for me.

It should be working.

I open the IF-A app followed by the IF app. I succesfully get the “Hey there Captain, ready when you are!” message. I start a flight and after that, nothing else seems to be working. None of the call outs work. When I try to auto-fill the V-speed, I get the following message :

Cannot Autofill
To autofill the V-speeds, first enter a flight in Infinite Flight in order for your aircraft to be auto-detected

Which device?
Did you update to the latest version of IF-A?

iPad Air 2020

I believe I am on the latest version because there is no update button when looking up the app on the App Store

After updating to iPadOS 17 I restored my iPad pro 10.5". And I downloaded IF 23.2.1 and IF-A 2.05 again, but this appears on the Warnings and RAAS page even after I restored the purchases


Edited: I reinstalled IF-A and it works now

1 Like

My problem still hasn’t been solved. Can anyone look into it? I have all callouts/commands/announcements/warnings purchased and have been trying to use the app with no success…

Hey there, can you confirm you have the ‘Infinite Flight Connect API (Experimental)’ setting checked within the general settings menu in IF

Yes, that box is checked.

That is for external devices only.
It doesn’t control apps on the local device connecting through the API.
Apps on the same device can always connect to IF.

Try deleting and reinstalling IF-A.

That did not fix it.

I’m out of ideas.
I’m unable to reproduce the issue.

I can reproduce this issue. I hear the connect notification but after that the V-Speeds give an error when pressing on autofill v-speeds button. In addition I can’t hear any announcements about the flaps, gear, pax etc.

Edit: I use the Samsung Tab S7+ with Android 13, One UI 5.1.1

No issues on the Tab S8 Ultra, with IF-A version 119.
I still can’t reproduce the issue on any of my devices.

iOS Devices:
- Apple iPad Pro 12.9 (2021 - 5th gen / M1)
- Apple iPad Pro 10.5 (2017)
OS: iPadOS 17.0.3
- Apple iPad Pro 12.9 (2015 - 1st gen)
OS: iPadOS 16.7
Android Devices:
- Samsung Galaxy S23 Ultra (2023)
- Samsung Galaxy Tab S8 Ultra (2022)
OS: Android 13
- Samsung Galaxy S10+ (2019)
OS: Android 12

Is that true that the app will help you to step climb in Infinite Flight?

Yes it does!

Also see this: