In-Flight Assistant - Bring your Infinite Flight experience to a new level! V-Speeds, GPWS, PA, and more!

After some health issues these past couple of months, I’ve now finished the update and it has been reviewed by Apple and is currently rolling out to the App Store! Let me know if you run into any issues.

NEW FEATURES

  • “Bushtalk Radio” integration: play audio tours of places you are flying over in Infinite Flight!

BUG FIXES

  • fixed a potential crash issue when purchasing GPWS functionality
  • include the v-speed estimation for the new Airbus 330-900neo and 777F
  • restore VNAV + flight plan functionality.
  • remove autopilot disconnect sounds from the planes that already have those built in via IF

Next up will be to update the Android version! 💪🏻

13 Likes

really appreciate your hard work, and great to hear you’re free and clear of those health issues.

1 Like

I’m Epaga very much of her work. Happy with this update. Most importantly I wish you good health (most important) and stay well @epaga !

1 Like

Probably a dumb question… im a relatively new user to the app so forgive me.

Does the app change languages automatically as you switch liveries, or does each flight attendant voice speak a separate language? I am in the process of doing a flight from Copenhagen to Paris and to my surprise, the flight attendant did the announcements in French!

Hey there! Unfortunately, the languages of the flight attendants won’t change automatically as you switch liveries. Each flight attendant speaks a specific language. Sean and Stephanie speak English, Adrien and Baptiste speak French. More are currently not available. If you want to change them, you have to do that in the app. Hope this helps! :)

Update ( June 21, 2022 )

Hey everyone - just wanted to give a long overdue update on what’s coming next.

First off, I want to apologize for the radio silence here on the forum (I’ve at least been trying to answer emails when I find time) - especially to those of you that had run into issues. Various things would come up each time I thought I was going to have some time to engage more and put out a fix… my laptop was stolen once, there were health issues, etc. etc… A big thank you to @Jan and others for “holding the fort” so to speak and helping people out where possible.

All of that to say…

Please contact me again if you didn’t get a response!

If you have written me in the past and haven’t gotten an answer yet, could you please try it again? The two best places to contact me are:

  • Via email (my email is found in the app)
  • Via the IF-A Discord (since I think I’m not allowed to link to Discords here, let me just say the link to the Discord is found on the official In-Flight Assistant web site.)

FAQ (Updated 6/23)

I’ll be editing this post, updating the current “FAQ” here:

Re: the waypoints of SIDs / STARs not being read

This is something I’ve now been able to have time to debug and the next update (iOS and Android) will include a fix for it.
(Update 6/23: Submitted a TestFlight beta build for beta testing this fix)

Re: the occasional crash on landing

I have not been able to reproduce this issue. If you could send me details of flights (especially if it happens every time for you!) that would be super helpful.

Re: Android + VNAV

This continues to not be something I’m planning any time soon because that feature is a ton of work and I definitely don’t have the time to implement it for Android at this point.

18 Likes

I hope soon, I stopped using the app.
Never flew without it before , but its become boring for me.

When your schedule opens up , I hope you can update the app for us Android users.

I mentioned to John several times and he was receptive to my thoughts on expanding the voices to include more accents. The few there are now are not enough.

He obviously is tasked on other things. So don’t know if more crew voices to select from will ever materialize. There is one with so much echo that its unusable.

Can we help with this ?

thanks

1 Like

My IFASSISTANT isn’t working well for a while now.

These don’t work anymore:
Minimums
Prepare for Landing
Short runway on approach

I think it is all working normally on my phone, including those calls… no idea how this is possible.

I love the app, I have been using it with my Android phone. My only complaint is the constant repeating of " Captain Ready When You Are." That starts randomly and because of this I miss ATC Commands. I have tried many things to resolve this but have learned to tolerate this annoyance by turning the volume down after take off and turning it back up on final. I like it so much, I haven’t given up on it yet.

1 Like

While IF Assistant is great and all, it would be absolutely amazing if you could make the “Minimums” callout configured via Altitude AGL, not MSL, as the callout doesn’t happen in high-elevation airports.

This is a small thing I noticed but shaky cam hasn’t been working in airplanes without a live cockpit (eg. 787 family, A380, B747)

Found the issue.
Not all aircraft are affected.
On aircraft that are affected, pointing down the camera view a bit makes Shaky Cam work again.
When the view is centered by double tapping, it stops working.

2 Likes

Android or iOS?

I just tested “Minimums” and had no issues on both Android and iOS.

1 Like

It may work on your end but doesn’t work with me. Hasn’t worked in over a year. The Minimums, Prepare for Landing and Short Runway On Approach.
I tried just about all aircrafts, settings and altitudes…nothing, they stopped working. I’m on iPad Pro 10.5” , iOS 15.4

1 Like

To test I started a flight on final in Solo for runway 06 at EHAM.

Minimums is actvated and set to 300 ft.

For me it works without issues.

Anything specific I can try?

I just tried an iPad Pro 10.5 and had no issues.

1 Like

Those announcements are working fine for me as well.

What could be the problem is that at some point during your flight(s), IF-A is disconnecting from IF due to some internet issue and therefore the landing call-outs aren’t working.

1 Like

Just tested it… working in solo… not working live.

Not that’s not the case… I have 500mbps download, 30mbps upload. The internet is not the problem. I just tested it again…. works in solo, doesn’t work live. 🤷🏽‍♂️ Everything else works but those commands on live. They used to work over a year ago.