In-Flight Assistant (Android): V-Speed Update (1.3) is out! Bring your Infinite Flight experience to a new level!

Here is your chance to save some money while you wait for the update to arrive on Android!

To celebrate the release of the amazing Global update, I’ve decided to offer In-Flight Assistant at 80% off and each in-app at 20% off for the next week ONLY - this offer begins today (as soon as the Play Store updates) and ends midnight upcoming Tuesday.


Will this be compatible with global?

Thank you very much @epega !! =)
Just purchased it and looking forward for the release of your instrument app.
Keep up the great work you delight us with.

Yes, it will be! I’ve been using it in the Global beta myself these past months - but it’s also compatible with the current version, so you can go ahead and get it before the Global update comes (out NOW!!!) and it should work great.

Oh also - if you could post a rating or review of IF-A when you get it, that would be most appreciated.

As am I! Combining the two makes for quite the experience! 🙂

Haha, you’re still wanting the slightly different “Retard” callout, aren’t you? 🙂


No, I was referring to the Spoiler induced drag sound effect 🙂.

Haha, that’s right! That, too! 🙂


I don’t mean to be picky, but does that mean that you’re confirming that you’re bringing it in the next update? If so, I’ll request the moderators to close my feature request of the same.

I am not going to promise it at this point, but yeah, I think I will. Leave the feature request open for now. 🙂


Gotta love some of these Play Store reviews.



Would some of you more … sane people … write a Play Store review? That’d be most appreciated.


Can’t.wait for android.

1 Like

You asked for sane people but I made one anyway :)

1 Like

I just bought IF Assistant but I cannot get it to work. I tried turning API off and on in the settings. I’ve closed out of both apps and opened IF app first. But whenever I’m rolling down the runway and cross the V1 and so on speeds and when I’m taking off, I get no commands at all. I get no “positive rate” “gear up” anything.
Am I doing something wrong? @epaga

Bought it instant ✅💯

1 Like

Rarely, some users had to restart their devices and it started working for them. You could try that.

1 Like

Thank you I will do so.

Curious - did this work for you?

Note someone on FB had an issue with which app launcher he used. He said:

Doesn’t work with Nova Launcher. Works fine with Evie.

No idea about either but something else to keep in mind.

Is global out for androids, yet?

Only iOS so far. Shouldn’t be much longer since the server issues have nearly stabilized.

1 Like

Patience is killing me.

1 Like

I tried restarting both apps and when I connect back in to both apps nothing happens. I won’t be asking for any refunds because I want to support you. Don’t worry about that 😉 I’m just disappointed in myself for not figuring out the issue. Thanks for your help though.