In-Flight Assistant (Android): V-Speed Update (1.3) is out! Bring your Infinite Flight experience to a new level!

I have never been able to repro issues people have here.
Im Android 7.0
I have never had issues, so most likely not the app itself but the way the app and IF are set up on your device


Me too, though it doesn’t bother me I suspect it got something to do with airports? Like, how different airports are made in IF and IF-A just detected what our eyes can’t see.

I have done that as well (this morning EST)…same issue…once the IFA is activated; it last for a total of 10-15, before it stops announcing anything. Therefore, i am forced to close the IFA app and open it again in order for it to work (on the ground or in mid flight)…I am not sure what to do or what might be the issue. Like I mentioned; I am on an Android-Samsung S9+ on T-Mobile. This started to occur in the last few days around Wed/Thursday is when I noticed the issue occurring. T-Mobile also pushed an update for Android/Samsung Phones which I updated as well during that time-period.

I already told the creator a few weeks ago the same thing that did not work told me that in android was something more difficult applications, but if the error does not work as before I have a note 9 and works perfectly ram and everything and the application has been missing for a month

Updates often change the settings that were changed in terms of the behavior of background apps.
They could have all been reverted to their default setting.

Please use the Android Connection Guide from the first post to check all the relevant settings again.

It’s also entirely possible that the update has a more aggressive way of handing (killing) background processes.

This is what makes Android difficult to work with.

what did you do in order to make it (IFA) work as designed?

Hello…following the Android Guide did not help; also I think the guide is a bit dated compared to what the set-up is on some of the phones…same issue continues:

Turn on IFA App along with IF app…
IFA app runs as normal, then within 10 seconds of any call outs…it stops…In the Android Apps, it shows its running, but there are no call-outs at all…
Only thing running in the background is well…NOTHING…I even turned off my Bluetooth where my Samsung Gear 3 is on…still an issue…cleared cache…nothing…still nothing…So I imagine, its not me; since it is happening to several people…

OK! Shame.

Were you able to add IF-A to the list of unmonitored apps?

The screenshot in the guide is from Android 8.0.0.

Could you make and send screenshots of the settings that are different from what the guide shows?

If certain things have changed, that information would be very helpful.


IF-A hasn’t changed, so it seems that Android has changed and is killing IF-A and other background apps.

If that is in fact the case, we have to figure out how to stop that from happening.

1 Like

Hello @Flight813 and @ALCO ,

Thank you for contacting In-Flight Assistant for android support!

I am one of @epaga’s beta testers and I have looked into this matter for you.

I have added both of you to this post so you can both test these steps!

I can confirm that In-Flight Assistant works absolutely fine without any issues on my end.

I have the same version of the app anyone can download from the Play Store with all the add-ons purchased.

My testing environment:

Huawei Mate 20 Pro
Android (with January 2019 security patch)

There are known issues with android itself, but it’s more related to manufacturers who are known to have aggressive background application management in their version of android.
One of them is Huawei. It seems now Samsung needs the same workaround as well!
This issue has nothing to do with In-flight Assistant as far as we know!

Solution or ‘What you need to do’ :

I have checked it for you with an over 6 minutes flight and I have received the relevant callouts during the whole flight and experienced no disconnections after following the above steps.

The menu system in the Settings on Samsung devices could be slightly different, but you have the option to search in the menu using the search field located in the top of the Settings menu.

This App Launch setting has to be done every time you uninstall and reinstall IFA. If you don’t uninstall it, as far as I know, you don’t have to do these steps, not even after an app or android system update. It is wise to check the App Launch settings though every now and then to make sure IFA is still allowed to run in the background!

Please report back at your earliest convenience if this solution worked for you!

Good evening,

No joy on my end with the Samsung settings…still the same issue…Works for about 15 seconds, then disconnects. I removed the app and reinstalled it…same issue (One time IFA came on mid-flight with the call-outs from the ground/flaps; yes weird; then disconnected…)Here are the screen shots for the Samsung S9+ Android…Software Update was made to phone Feb 18 2019 on Android v9.

20190224_182406 Screenshot_20190224-181248_Settings


So Background Activity for IF-A has been turned on in the settings, but it doesn’t actually seem to be working. 🤔

Shame @Jeno_Farkas’s tips didn’t apply to Samsung as well.

Unfortunately I can’t test Android 9 at the moment.

I use two devices to test the app.

  • S8+
  • Tab S3

My S8+ is supposed to be getting the Android 9 update soon. “Starting February” is all I could find, so no exact date.

The Android 9 update for the Tab S3 is supposed to be planned for August 2019. So that will take another six months.

We, @epaga, @Jeno_Farkas and I, will try our best to help though.

Are there any other (hidden) settings that you can find that have to do with background activity?
We have to find a way to keep Android 9 from killing background apps.

Could you see what’s under “Optimize battery usage”?
That is something that should be prevented.
Can it be turned off?

Well, it seems your settings menu is different so I’ve Google it.

What you are looking for is Settings > Device maintenance > Battery.

Based on your screenshots, it seems to be renamed to Device Care.

There is a list under this option.
One meant to say Always sleeping apps, the other one meant to say Unmonitored apps.

What you need to do is to have IFA in the Unmonitored apps section! This prevents the system to close IFA when it’s not in the foreground (as IF runs on the screen).

1 Like

Hey everyone - sorry, I was gone this past weekend on a trip so only now am seeing this thread - thanks so much (as usual) @Jan and @Jeno_Farkas for being so helpful!!

In addition to their tips and the Android guide, I’d also recommend this web site:

Android unfortunately causes lots of headaches for apps that are intended to run in the background.

1 Like

Let’s try to figure out what’s going on.

Were you able to go to Settings, Device Maintenance (or Device Care), Battery and scroll all the way down to Unmonitored Apps?

The fact that one of your screenshots is showing the app list under Battery, which has IF-A on it, means that the app has NOT been added to Unmonitored Apps!!

When you add IF-A to Unmonitored Apps, all should be fine!

1 Like

@epaga would like to know if it opens android update next, is the apk that gives more brightness to IF flight and is quite outdated

I guess you haven’t been on the forum long enough to know that questions like these are totally useless.

When will work start on an update?

When the developer chooses to.

When will it be available?

When it’s ready!

Just be patient! 😉

1 Like

your esque tarot or something …? I ask to know if there is any news or if you are working on it.

As soon as there’s any news, it will be posted here.

1 Like

@Flight813 @ALCO did Jan’s and Jeno’s tips about the battery help you with your issue?

no news

since the last update the program kills the processes in the background, even though removing them happens the same