In-Flight Assistant (Android): V-Speed Update (1.3) is out! Bring your Infinite Flight experience to a new level!

@epaga hey thanks for your quick reply. I had already arranged the settings according to the guide, and the connection is fine. In fact, the app stayed connected for a whole 6 hr flight. The issue is that at times its like the co-pilot doesnt respond when he should and then does, and the PA mixes up what it is supposed to say.

Very strange indeed then! Try rebooting your device. Perhaps it was low on RAM or something? Is it only that aircraft?!

@epaga No, I have more than sufficient RAM. And I’ve rebooted the device multiple times

I notice also that on starting IF it doesn’t always say the “Ready when you are Captain” when starting IF for the first time. But the app is somhow connected, as the co-pilot says stuff randomly…just not always how it is supposed to.

Maybe I should uninstall and reinstall? Would that restore purchases for the PA IAP?

Mine is running Okay and has done all day

That’s really strange.

@epaga, I tried again this morning. 5 hr flight from OMDB to LTBA in B777-300ER and it worked absolutely flawlessly the whole way, so it seems to be random.

I’ll keep testing and keep reporting back.

1 Like

@epaga, So after a couple more flights, I have definitely noticed that there seems to be a difference between how Boeing and Airbus aircraft are handled?

After the flight in the 777, I tried a flight in the 737-900 (4 hrs), which was also absolutely flawless. After this I again tried an Airbus (320), for a short flight of just 1 hour, and I again had issues similar to what I reported last night. The co-pilot did not call out v1, vr, v2, gear up. The other calls and the PA were fine though. I hope this narrows it down a little.

Can the pushback be changed with the engine start briefing?

Hey @epaga, I think I found a solution. It does not seem to be linked to aircraft at all, but rather when I finish a flight, end it (go back to the main menu), and then start a new flight without force closing both IFA and IF. It seems to me that when I start a flight after opening both apps “fresh”, if you know what I mean (sorry, English isn’t my first language), then IFA works flawlessly.

EDIT: scratch that. I’m really confused about this.

Confusion re: connection issues is almost always Android throwing a wrench into stuff. If you don’t want to upgrade to iOS 😜, check out for more detailed instructions (could be something is there that is not in the guide).

What device do you have?

Android really needs to get their act together, it is such a pain because there is often no way to control when it shuts down background apps.

Yep - there’s a setting in PA: “Pushback First”. Flip this to flip it.

1 Like

Thanks, I’ll check the link. I have an Honor 9, which is the same software as Huawei. I’m on EMUI 8.

By the way, I love the app anyway, when it works it’s just super!

1 Like

Hi there @AirMajjistral,

Solution for you:

Settings > Battery > App launch.

Search for IFAssistant and from automatic change it to manual, with the settings below.
(Works with EMUI 8.1 and 9, tested on P20 Pro and Mate 20 Pro!)

1 Like

Hey @Jeno_Farkas, thanks for your help. I had actually already changed my settings like this when I first bought the app

1 Like

I have read it on another forum while I was doing a research for my issue (sudden and unexpected closure of apps without crash report pop-up), that one of the latest software updates for Honor devices has a bug which sometimes result in app closures even when manual app launch is selected.

One thing you can try out is to go to Settings > Apps and look for your app list. (on emui 9 is Settings > apps > apps)
Top right corner has 3 dots, tap on it and choose Show System Processes.
Put Webview into the search box on the top part of the window, and look for Android System Webview.
Tap on it, which will take you to the app info page. There you need to tap on Force Stop.

Reboot your phone, then go back to your app list following the same steps to verify that the Webview process has not started after rebooting. If it did restart, force stop it again, but don’t reboot this time.

Launch IFA (keeping the manual app launch settings) , then launch IF as normal.

Do a flight and let us (me) know how it went.


It doesnt give me the option to flip it. It only states enabled and a box to check.

Spoiler alert!
That option isn’t available in the Android version yet! 😉


LOL, oops. 😂 Sorry…it’s coming sooner or later, though!


Hey @epaga I am experiencing a problem with the application, whereby I’m not getting certain call-outs such as the After Initial Climb, the Snacks & Drinks, the After Landing and the Soft Landing when landing under 350ft/m. These are all from the PA purchase I made some days ago. Do you know what this may be due to?

I also sometimes receive speeding warnings on the runway too.

Do you know what these are due to and how they may be solved? I’m on a Galaxy S8 if that helps. Appreciate your time, cheers!

First of all, check this page: It could be your phone is shutting down the app at times and that might help mitigate the problem.

Other than that, I think there is a bug that changes to things like the initial altitude and others won’t work until you restart the app, so try not to change any values and start a flight over.

Finally, here is a callout guide which explains each callout. Make sure you’re actually fulfilling the conditions:

If this doesn’t help, please give me an example flight plan you are flying along with the altitudes and which airplane model you’re flying, and I’ll see if there’s anything I can do to reproduce it.



Cheers for the detailed explanation, I will check and let you know if there are any further problems. Thank you for your time!

1 Like