In-Flight Assistant (Android): PUBLIC BETA 1.3 RUNNING!

#546

Is the voice feature on Android too? Cause then yes, I understand that that would already serve that purpose.

#547

it would be incredible to have the new version for when the new update comes out, waiting for your great job @epaga

#548

im excited to here my voice finally out on android. i have been waiting so loooooong.

3 Likes
#549

Not yet…which is why your idea (which would likely be easier to accomplish) is kind of intriguing…but will have to think about it.

2 Likes
#550

Hello! Got a suggestion : Setting to be able to choose between GPWS or TAWS (aka the old GPWS) What do you think? 😁

1 Like
#551

Hello, so with the new update, your app does not work anymore. It doesn’t connect to the app as it usually would. If you could get it fixed, that would be amazing!

1 Like
#552

@Samuel_Szeto what are your steps to repro ??
i have no problems

2 Likes
#553

Yep, never mind. I found out what went wrong. I dowloaded the app again due to the bug, and all my settings got reset. Which made the infinite flight connect off.

2 Likes
#554

haha, good. always good to double check in future

2 Likes
#555

Phew! Thanks for the minor heart attack right as I was going to head off to bed. 😜 I’m a beta tester and had had no issues during testing…but there’s always the remote possibility there’s some side case I didn’t catch.

2 Likes
#556

Im a beta tester too so i can catch anyting in future builds but will DM you for that

#557

Hi,

I am having a problem with connection of IF-A to IF since update. Note that IF Connect and Run in Background setting are enabled.

Device: Huawei Nova 3i
Android Version: 9 (Pie)

Been doing Solo only as I am unsubscribed at the moment. Can reproduce.

Hoping someone can assist.

Thanks in advance.

#558

@Ren
what are your steps to connecting and running the apps together when going for a flight ??

#559

1st: Opened IFA;
2nd: Opened IF (Ready when you are, Captain uttered);
3rd: As soon as I entered flight to check connectivity, I set flaps to 1 (used A321). Heard nothing. Tried others as well like pushing back, starting engine, still heard nothing.

Edit: Redid to check. Same issue persists.

2 Likes
#560

I can confirm there are issues.
Looking into it now.

2 Likes
#561

Could you check this page - not sure how different the settings are here but there are probably similar ones on Huawei Nova 3i? https://dontkillmyapp.com/huawei

Would you mind giving me a screenshot of your settings on those pages? That would help to figure out what Huawei on Android 9.0 is doing…thanks!

1 Like
#562

Here’s the setting I am using before and after 19.1:

1 Like
#563

Thanks! Is it possible some of these other settings are also there?

  • Phone settings > Advanced Settings > Battery manager > Power plan is set to Performance
  • Phone Settings > Advanced Settings > Battery Manager > Protected apps – check for your app as Protected
  • Phone Settings > Apps > Your app > Battery > Power-intensive prompt and Keep running after screen off [x]
  • Phone settings > Apps > Advanced (At the bottom) > Ignore optimisations > Press >Allowed > All apps > Find your app on the list and set to Allow

Huawei P9 Plus:

  • Phone settings > Apps > Settings > Special access > Ignore battery optimisation > select allow for your app.

Huawei P20:

  • Phone settings > Battery > App launch and then set your app to “Manage manually” and make sure everything is turned on.

Huawei Honor 9 Lite and Huawei Mate 9 Pro:

  • Phone settings > Battery > Launch and then set your app to “Manage manually” and make sure everything is turned on.
2 Likes
#564

On Samsung devices running Android 9/Pie, two separate settings have to be changed. One under Battery and one under Memory.

Battery:

Settings -> Apps -> scroll down to IF-A -> Battery -> Optimize battery usage -> select “All” instead of “Apps not optimized” -> scroll down to IF-A and flip the switch off. The app has now been added to the list of Apps not optimized.

Memory:

Settings -> Device Care -> Memory -> Menu (top right) -> Apps that aren’t checked -> add IF-A.

This will solve the issues of IF-A disconnecting after some time.

Doing the same for IF will prevent IF from stopping when you switch to another app for a short time.

3 Likes
#565

Thanks so much, Jan!

Android, man - I don’t know how you guys put up with it.

😂

3 Likes