Impossible to land/takeoff in New Zealand, Istanbul > Crash !

Hi there. I experience some serious issues when I try to land or takeoff in Auckland airport, same with Istanbul and many other airports. When I arrive on the runway, the plane just “sink” into it and falls into the void. Same whe I try to takeoff and it crash ! And it’s the same for ALL airport in New Zealand !!

Tried to restarts etc but it seems that it doesn’t solve the issue. I just made a 14H flight and could’nt land, it’s frustrating really, needs an update and feedback from you guys ! Thank you !

1 Like

Corrupt files. Have you tried reinstalling the app?

1 Like


This sounds like a simple case of corrupt terrain data. Normally, a simple restart should help but in some cases a reinstallation of the app is required.
And in your case, a reinstall of the app seems like the next logical step.

You should be fine after that.

Thank you!

1 Like

You guys are soooo quick haha !! Thank you so much ! I will do it ! Have a wonderful weekend ;)