IFATC Grade Eligibility Error

Hi There, I am currently trying to apply for IFATC recruitment however, when trying to apply, it says that my account is not Grade 3 however I am. Is there anything that I can do to fix this issue.

Many Thanks, Will

Device: IPhone 13
Operating system: IOS 17

Your linked account is Grade 1 and it’s a blank account. I’ve deleted it now.
So for that to work, you need to link your Community profile to the correct account that is Grade 3.

1 Like


Now I get this message although I do not have any violations ?

Ouch!

I see that you had a violation reversed just 2hrs ago so might be related to that, but I’ll check and get back to you asap!

Thank you, thought it could be related to that. I received the violation for crossing a runway even though I got clearance so has been a pain to get that removed.

Thanks for the help.

Hello!

Can you try again now?
If not, try a different browser if possible or clear out your browser cache.

1 Like

Hello,

I have tried all of these and still comes up with the same message ?

Was wondering if you got any more information about this ?

I’ve forwarded in internally for additional check! Sorry for the delay here.

Hey William, would you mind just starting a flight then trying again? That should refresh your stats in our cache which should then allow you to apply.

I have just tried this and still not working ?

Looking into it now for you!

Hi William,

Looks like you’re already in the recruitment process and it was giving you the wrong error code for some reason. I’ll look into that, but for now you can refer to your recruitment DM from the bot for further info on the status of your application.

Cheers,
Kai

1 Like

Hi Kai , yep got it sorted last night,

Thanks for the help though

1 Like