IFATC application "IFC linked account not found."

Hello all,

I have finally found the time to grind out my final landing requirements to reach the Expert Server and am currently attempting to apply for IFATC. I love playing as ATC more than I enjoy flying 🙊
I’m having an issue with the application service. When I’m filling out the application it states that my IFC username is confirmed valid but whenever I send my application I receive an error that “IFC linked account not found. Please link your IFC account in Infinite Flight, do a quick flight, retry your application and ensure the IFC name is typed correctly.”
I have tried applying mid and post flight but still receive this same error.
[EDIT: Also, can confirm that my IFC account is linked with my IF client.]
Attached is a photo of my initial application showing my username is valid and the error I receive after pressing send.
I hope someone can help me out here and I look forward to (hopefully) one day being your ATC during your Expert Server flights.

I would tag support in this, or contact an IFATC Mod/Supervisor to help you out! I’ve never heard of this issue, maybe go and update your profile and see if that changes anything?

1 Like

Hey Drew,

It’s fantastic to see that you enjoy controlling on Infinite Flight and are looking to join IFATC. It’s a great team of people and you’ll love it!

I believe the best option in this scenario for your application to process correctly is to wait until you finish the current flight that you are flying and then head into your settings and link your IFC account to your Infinite Flight account.

Once you have tried that, do a quick flight as mentioned above and retry your application. Remember as well that you need to put your IFC name in the box underneath requirements.

Let us know if that works or if you have any further issues.


Speak of the devil 😈

Will do that now. I’ve finished my current flight. I will now reopen IF, relink my IFC account, perform a quick flight, and attempt to reapply. Thank you guys so much for the quick response! I’ll reply again once I’ve attempted this.

1 Like

Awesome, let us know if it works. Fingers crossed. 🤞

Hazaah! It worked. Cool.

If you guys could archive this? I specifically used the entire quote of the error to allow for a simple search for others in the future.

But yes, the exact process that worked for me was to completely close IF, start the app, unlink my IFC profile, relink it, and I personally did a small LAX 24R to 24L loop on the Expert Server. My application has been submitted successfully.
Thanks again guys.

Awesome, glad to hear it has worked for you. Looking forward to seeing you apart of the IFATC team soon!

Thanks all!