IF crashes while choosing an Airplane and can’t connect to FDS Servers

Today, I was on Solo on the Etihad (2015) Airbus A321 and I started from EHAM Gate H07. Due to some reason (it’s personal) I had to exit but I forgot to directly end the flight on IF, and it was also updating the planes. Now, IF keeps on crashing while tapping on the aircraft menu button and can’t connect on a 610 Kbps connection though it did work before.

Device: iPad (5th generation a.k.a. 2017)
OS: iOS 10.0.2
IF version: the latest version (#TooLazyToCheckTheAppVersionOnTheAppStore. ;-). )

What I have tried:

  1. An app restart
  2. No background apps
  3. Clearing the RAM (after that was suggested by @cleipelt)

What I can’t do right now:

  1. A reinstall due to slow WiFi speed

EDIT: I just checked on fast.com and the WiFi is 1.6 Mbps right now, but it can’t even establish a secure connection.

Why don’t you try to shut down your iPad (holding the home button and the power button at the same time) let it sit for a few minutes then get back to us. :)

I could do it but then my mom will ask why I frequently restart the iPad. Also, I don’t have the passcode so I won’t be able to use it for the next 3 hours in that case (parents are out for official work)

Maybe a good long restart would do good for it though. It works for me all the time, so it might be something to consider.

1 Like

Yes, but I have to wait for the next 3 hours to get any results.

True, maybe wait about two hours so that you on,y have to wait an hour. :)

1 Like

Perfect. I finally managed to spawn at EHAM Gate H07 on Solo and right when I switch to another camera view, crash. 😡. Thank you, App Store and Safari, you were on Background.

On the other hand, the aircraft menu glitch was solved but I have to download all the aircraft except the Cessna 172 and my Airbus planes. 😳

Try clearing out the RAM since you can’t restart.

1 Like

Do that by holding the power button until the slide to unlock comes up and then hold the home button down.

But yeah, a restart would almost certainly fix this.

1 Like

Hmmm… Has actually happened to me before. I don’t know the exact reason but whatever the reason is, you don’t have any other way other than actually downloading the aircraft(s) again. But for purchased aircraft, you don’t need to pay again. If you tap on the “Restore Purchases” button, they will be available for download without any charge.
For that other problem you have, clearing the RAM and/or restarting the iPad will probably help.
Hope this has helped
LamborghiniLife

1 Like

Did it just now, and updated to the latest version after I realised that I was one version behind. This same problem just ruined my Asphalt 8 about one hour ago.😡😢😭

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.