I try to purchase but it says please wait

I’m trying to get a one month subscription to infinite flight, however when I try and purchase it says please wait, and doesn’t finish loading

I have an iPad from 2017
Very good WiFi
Already restarted the iPad
Tried deleting and reinstalling app

I have found that if I try and select the 6month or a year option it takes me straight to the thumbprint verification however still only stick on “please wait” when I try the one month option.

Hi Luca! I was chatting with you on the IF IG inbox. @schyllberg will be with you as soon as possible to help.


Also, welcome to the community.

1 Like

Hey Luca!

I’m not Seb, but perhaps I can try to help you out before he takes over to speed up the process. Your explanation leads me to believe that there might be some parental restrictions enabled on your Apple ID which might be causing this issue. Can you please check if there are any enabled?

You can check this by following these steps:

  1. Go to Settings and tap Screen Time.
  2. Tap Content & Privacy Restrictions. If asked, enter your passcode.
  3. Tap iTunes & App Store Purchases.
  4. Check if anything is blocked.

Let us know if this is the case & welcome to the Infinite Flight Community.


I have checked and nothing is blocked, however whenever I download an app or purchase something my iPad has to get permission from a parent. I don’t think this is the issue though because I have previously been able to purchase the 1 month option before with having to ask for permission.


Unfortunately that would be the issue exactly. Other apps are having similar issues it seems.
We’ve tried our best to investigate this to see if there’s anything wrong. But in the few cases we’ve been able to reproduce this, it’s been an issue with us not getting anything back from Apple. So something is not working as it should on Apple’s end unfortunately.


emmm, I’ve also experienced this error, and this is due to parental control, make sure you disable it before purchasing the subscription.

1 Like

My parent has disabled the parental control yet when I try and purchase the 1 month option it still says please wait. But if I try and purchase the 6month or 1 year option (which I don’t want to get) it takes me straight to the thumbprint verification and I would be able to buy it, frustratingly it will not reach this stage with the 1 month option which is the only option I want to buy.

Don’t worry! I have solved three problem. How I did it was instead of purchasing through the app I went to settings, then subscriptions and did it through the settings app. Thanks for your help.

1 Like