I have discovered a weird glitch in the KC-10 USAF refueler

Is it just me or is someone else experiencing this glitch ? I am really confused about what is happening. Whenever I have initiated a push back everything goes normal until I have clicked on the “Stop Push back” the aircraft’s nose goes up and I start travelling forward although my engines are all switched off.
At the time of the Incident here are some details:-

1.Time when incident took place:- 13:15 IST
2.Server:- Training V2
3.Aircraft:- DC-10F
4.Display name:- Cpt.Arghya
5.Callsign:- REFUELER
6.Exact weight of the aircraft:-238,544 KGS(Metric)
I really hope someone will be able to solve this problem thank you for reading ;-):-)

I’ve experienced this myself.
I’ll admit, I was messing around, but it was still strange.

1 Like

Are you still experiencing this problem ?

Thos just happened to me last night. I’ll see if I can make it happen again.
However, since it happens to you, I presume that it’s a bug in the IF code itself.

1 Like

I’ve had this too. Bit surprised at first

1 Like

Thank you @AIDoLS and @morgan99 for communicating hope IF dev team fixes this soon

1 Like

Here are some pictures.
I tried this on Solo. Last night it was on the Casual server.
The pushback button is stuck at “Stopping Pushback”.

This isn’t solved yet. Don’t count it as solved please…
@AryaTheLivingMeme This is not solved. Please deselect the solved button so that moderators or developers can see this to fix it.
Never mind then, it’s solved now. Thanks @dush19!

1 Like

This is a known issue and has been conveyed to the developers, will be fixed in the next update.

4 Likes