I can't update IF on my Nexus 7 (2012)

I just formatted my Tablet and install infinite Flight but I realized that it was not Global, it is not compatible? My Android version is 5.1.1

That device is very old and probably doesn’t support Open GL 3.0, which is needed for Global.

More info here:

1 Like

Hello!
Unfortunately your device is not supported as the GPU it is equipped with only supports OpenGL ES 2.0.

1 Like