I can't load into any flight

I tried many things. I deleted and reinstalled, clear cache, clear storage, tried different wifi’s and even tried using data.


This is what happens. It says that I’m not connected to the global server. The only thing that shows is the UI. BTW, I have a Pixel 3a that I just got last month. Can someone pls help me?

1 Like

have you tried turning the phone off and then back on? just asking

Yep I do that at least 5 times everyday because I have to turn off for school

It doesn’t look like an issue on the server side. I can connect to the server. How’s your connection generally? Maybe just slow?

It’s always been fine, about 100mbps. However, the problem’s beens happening for the last two weeks and it doesn’t want to work.

Any chance that it’s on the ISP side? Like the ISP blocks the port live server uses. Seb can definitely help better. Let’s just wait for him to respond :)

Excuse me for my lack of knowledge, but I have no idea what ISP is heh

It stands for Internet Service Provider :)

Ohhhh… then Ive no idea I use t mobile for my data.

Does Spectrum ring a bell? I had this happen to me for a bit but reinstalling fixed it.

Also, what’s so spectrum?

Spectrum is the largest ISP in the United States

I see. I use D-Link. Also I found something else that doesn’t work.


The map won’t load either, so I have to search up the airports.

I’m stumped. Has anyone else got any ideas?

I still firmly maintain that this is an ISP issue. Do you have a VPN? Try connecting to a VPN and see if you can connect

hey, i got it. For some reason IF didn’t really finish downloading all the data. But after VPN it fixed it and now the flight and the map loads. When I turn the VPN off, it works fine again. Thanks.

2 Likes