I can't download the global update?

I can’t download the new update. It says I need iOS 10.3.2 or above. My device satisfies this requirement with iOS 10.3.2. (Upgrading to 10.3.3) My device is an iPad 4. I have tried restarting, to no avail. Please help.

5 Likes

Having the exact same problem

5 Likes

Hmmmm…exact same here (Ipad 4 version 10.3.3)
guess its over for us… : (

[IMG_1086
Same issue here might be done for IF because I Can’t afford a new iPad

1 Like

It’s odd though. I don’t need opengl 3.0 because I’m not on Android. Unless I’m very much mistaken.

1 Like

Laura said it’s issue with App Store I Made a support Topic on Apple support hopefully they respond shortly

1 Like

“Android devices needs to support OpenGL ES 3.0 (should be supported by most devices with at least Android 5.0 but unfortunately this is not guaranteed by each manufacturer).
Devices that do not satisfy those minimum requirements will not be able to update.
Introducing Infinite Flight Pro”

It only mentioned opengl could be a problem on Android. It didn’t say anything about iOS.

1 Like

Well it doesn’t matter too much to me at the moment, since I’m going away for a few days. For planespotting no less.


Take a look here.

1 Like

infinite flight global requires iOS 10.3.3 or iOS 11

It requires 10.3.3 so…dunno

My iPad mini 4 16 bits is an iOS11.0.2 and it shouldn’t be a problem but if I see that, I am gonna contact Laura on Instagram. But it shouldn’t be a problem because it’s the apple latest iPad version

I have the same problem

Your mini 4 should be okay as it has met the minimum requrements.

1 Like

This seems to be an issue with iOS. @Cameron is looking into this

Please be patient while we work through some issues.

7 Likes

According to the device compatibility list posted by Laura, I’m afraid your iPad 4 is not supported.

57531C6C-EFC2-46A9-BBBB-AB594A82BC65

1 Like

The iPad 4 is not a 64-bit device, which means that unfortunately it is no longer supported.

1 Like

It’s. Over iOS 10 though so we will still get the update

1 Like

I think that we need also a 64 bit iPad… not only iOS 10.3.3

That’s interesting… Could it be because of so many trying to update it at the same time?