Huawei p8 lite problems

It seems you are running 16.13

Like @Chris_S said:

The reason you have an older version of the app, is most likely because your device does not support the most recent version
Please read below about the older device requirements.\

Android Requirements:

  • Android 5.0 (Lollipop) operating system or later
  • Device must support OpenGL ES 3.0

Note: Due to large variety of Android devices there is not a specific list of supported devices. Customers with devices that are not supported at this time will receive a message on the Google PlayStore when attempting to download the latest update for Infinite Flight to advise that the device in use is not supported.

I recommend checking out this thread to get an idea of what Android phones can steadily run the latest version of Infinite Flight.

1 Like