Horizontal stabilizer glitch

I was taking off in SBRJ and the Horizontal stabilizer was facing all the way down and i had no trim on. I tried calibrating many times but it was still in that position which looked like -100 percent. So i thought it was maybe just a glitch with how it looks and not how it flys. So i tried taking off and i crashed right in to the water because i could not create lift. It was just this one flight and i have not started another flight so it will probably be solved when i start another flight. But what i want to know is what happened? Can anyone help?

Did you calibrate and set the trim?

Yes. I tried tried trim 100 percent.

Read his post, he clearly says that he has done that already :)


When this happens, try turning the V/S autopilot mode on and off, this usually solves the issue.

1 Like

Did you set your aimed altitude in the Autopilot?

I dont think so

If you activated the autopilot and your autopilot altitude was 0, then expect to fall in the water haha.

I think that was probably it but i thought my autopilot was off.

Does it show in replay

I looked in replay and I’m 90% sure thats what happend

1 Like

Do you ever use a joystick to fly? You may have forgotten to reset the rudder input. If this isn’t the case, likely your autopilot was set.

Did the yoke move at all?

I figured out it was the autopilot

2 Likes