Help please

My throttle just cut and I am at 28,000 feet currently gliding down it says my device was being used else where and it wasn’t please help my throttle hasn’t gone back

21,000 feet

Hi there,

The best way to fix this is to exit out of the flight, restart the app and try flying again. If that doesn’t work, PM a moderator with your callsign and display name and they can view your recent account activity and determine if someone else is using it.

1 Like

Probably A Server Reset
Happens To Me Alot (during 16 hour long hauls) and There isn’t anything to do about it sadly ):

Welp great know I have to end my flights thanks for the advice I guess I will do

Ending your flight is better than crashing, don’t want that to happen!

RIP LLBG-KSFO well I tried man that sucks

Maybe you ran out of fuel?

issue has been solved by Chris!

1 Like

I definitely did not run out of fuel I have been watching the whole time but instead I decided to fake squeal 7700 and crash land right in front of runway 19 at EGSP barley missed it

1 Like

As others have said, You will have to end your flight :(
Shame that you had to end a 14ish hour long flight.

1 Like

It’s all here :)


Nope, This would not cause this error unless we reboot the entire Live environment, which we would never do unannounced or if there wasn’t a major issue :)

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.