Hard Landing / ATC

So there I was, (FedEx 147 Heavy) inbound on the ILS RWY 09L into SBBR. Nice and smooth all the way, touchdown, Nose still up, take it off APPR and BOOM nose slams down into the runway therefore glitching my NLG into the ground, unable to turn, all at the same time I have ATC yelling into my ear to vacate the runway but I’m unable to move. So instead of risking being reported I just ended my session. Was that the right thing to do or would I of been reported if I stayed there unable to turn?

1 Like

Looks like you fell through the ground unfortunately. Clear your Scenery cache to fix it. If you were reported it would have been reversed, this is an issue you can’t control. Sorry about that! 😊

5 Likes

looks like u jus dogdged a bullet my friend u would of ended up calling the number lol

3 Likes

Sounds good. Not putting blame on anyone except for myself I guess, but thank you for the support. Maybe I’ll just try not to bash the nose into the ground next time.

1 Like

FedEx 147 Heavy… I have a number for you to copy when you’re ready 🤣🤣

8 Likes

You did the right thing in the scenario. If you are stuck, whether it be on the runway or a taxiway, it’s always best to end your session as you would be blocking the runway or taxiway for other aircraft arriving and departing.

8 Likes

Hey! Adding on to what @Sashaz55 said above, you did the right thing when you ended your session. There would have been no way to get out of the ground, causing go arounds, etc.

What Declan said, we posted at the same time.

2 Likes

Unless Infinite Flight adds a tow vehicle for crashed aircraft 👀

4 Likes

Everyone spawns a tow vehicle at the gate 😂

4 Likes

I know this is a repeat of what @Declan_O said, but I have actually had my nose fall through the ground when lining up to wait in an A380 way be when, told to take off, then expedite, then ghost. I was mad because I believe in realism and thought I could play it off as an emergency, was sent to training server for 7 days. Good choice!

1 Like

Did appealing not work? That would certainly be classified as a report caused by a glitch.

1 Like

The only thing that might have worked is to go full power and you might be able to fly the nosewheel out of the ground. Otherwise yeah end the session.

To me it looks like you forgot to calibrate your device before taking off APPR, look at your TRIM box.

1 Like

Actually, you can (sometimes). If you bring down the nose hard enough, you can get this to happen all the time. If you manage to get some speed, you can pull up sharply and you can free yourself.

I was stuck in a taxi way on if and tried that but forgot I was in online and got like 2 violations. But I got it out of the ground 🙃

I honestly cannot remember if I did appeal or not, this was a long time back so I cannot remember it at all.

All you gotta do is give yourself some throttle and pull up. Works everytime.

Tried that with no luck

Not every time. Sometimes there is not enough thrust to actually accelerate at all.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.