GPS and ILS alignment issue

Hello all, Hope everyone doing great!

Coming to the issue, for past few day’s I can’t able to align with the runway properly while landing. Tried both GPS and ILS it can’t able to align in the final vectors. Even if the wind is calm still it occurs! Confused that it is my mistake or glitch. Please help me out.

1 Like

Hey I think this is a known issue and nothing can be done in the immediate future to solve it.

Also please set the topic to support


Thanks for the reply! I thought this is happening only for me. Sure will change the topic to support

1 Like

It could be as I see the other aircraft are aligned… Maybe you did something wrong in your ILS procedure. I know this issue happens at some airports but that’s to be confirmed still…


Sorry for the late response, Yes! I even noticed that too in some airports this happens, but for me at every airport this happens for past few day’s. am totally confused that it’s my mistake or a glitch, if it’s my mistake could you please explain or suggest me some video to how to do a proper GPS or an ILS approach

This would be helpful


Thanks for the reply! Tried the APPR too but the result is same.😞 I almost tried each and every method but still can’t able to make, though am confused that i was my mistake or glitch

If not you can use approach procedures, those can get you aligned

1 Like

Sure will try that, Thanks a lot!

1 Like

I tried multiple times landing the aircraft using appr and ils.Despite switching on appr and ils at correct altitude the aircraft is not lining up with the runway to land but its going away climbing steeply up and down and when switching off the autopilot the aircraft is stalling and crashing.This is really frustrating.If this issue is not fixed then game itself is waste.How to fix this issue?

1 Like

The steep up and down maybe coz of the flaps, try to set the flaps according to the speed and wind. Please check the user guide for more information on your queries, you can able to understand easily on that.

Coming to the alignment, My issue got fixed once I tired APPR. It worked for me to line up with the runway. Firstly to use APPR you need to be at 3000ft. and at or below 200kts, try to switch the APPR before 15nm and The main thing is you need to approach the final vectors in certain directions (please check the ILS procedures in user guide) If you have done the above things properly and still if the problem occurs it maybe a glitch! Let’s hope that it ll be fixed in next update.

APPR mode in IF is a bit interesting to say the least
The AP system in IF is known to have room for improvement but it’s still plenty good for now