Google play issues

I am currently experiencing issues when I try to purchase online, when I try to purchase Google play store just sais “error while retrieving info from the server” this is very annoying and could somebody please help.

1 Like

Do you have a stable internet connection?

1 Like

Yes I have turned it off and on however nothing seems to work

1 Like

Make sure to have good wifi or data connection before proceeding. Let’s go ahead and try a simple solution by restarting your device and try again. If that doesn’t work, go to Settings > Apps > All > Google Play Store > Clear Cache. Also clear the cache for Google Services Framework.

Hope this help 😉

1 Like

This has not worked what now?

2 Likes

Playstore error messages are sometimes fixed with clearing the cache as mentioned above.

-Try signing out of your play store then restart your device and sign back in. Also make sure you don’t have any blocks or permissions in place for purchases.

-You could also try hooking your device up to your PC and update/make purchases through your PC.

2 Likes

There are a few things you can to do fix the error.

Clear cache and remove Google account
This solution was posted on the Google product forums and worked for most but not all users.

  1. Navigate to Settings, Storage & USB, Chached data and select Clear cached data.
  2. Navigate to Settings, Apps, Play Store, Storage and select Clear cache.
  3. Navigate to Settings, Apps, Play Store, Storage and select Clear data.
  4. Retry the Play Store and download the app.

If you still see the ‘Error retrieving information from server [RPC:S-7:AEC-0]’ error try removing your Google account. You will have to re-enter the account before being able to download from the Play Store though.

  1. Navigate to Settings, Accounts and then Google.
  2. Select the three dots top right and then Remove account.
  3. Reboot your device.
  4. Navigate to Settings, Accounts and Add account.
  5. Add your Google account and retry the Play Store.

You should now be able to access the Play Store as normal and download your apps without seeing ‘Error retrieving information from server [RPC:S-7:AEC-0]’. Don’t forget to let your phone sync after adding your Google account!

Stay Safe
Avex_91190

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.