Google pixel 3 charging while flying

With the latest google phone (Pixel 3) there seems to be an issue with putting the device on charge mid flight. Ive tested this on multiple settings from highest to lowest and every time I plug the charger into the device mid flight the game freezes, comes up with Infinite Flight Not Responding and proceeds to close the app. Anyone had similar issues or know a fix?



Hmm. There may be possible reasons on why this may be happening. Have this in mind that these are just my opinions.

Firstly, check if your charger is faulty or damaged. This may lead to connectivity issues when responding to charging devices.

Either way, check if your phone is faulty. Lower your brightness and make sure your device does not overheat. which leads me up to the next steps.

  • Make sure you reboot your device before every flight.
  • Make sure you download and reinstall Infinite Flight if this problem persists.
  • Make sure to have plenty of storage when running Infinite Flight. At least 1Gb is Recommended when running this application.

Tried all of the above, ran diagnostics on the phone as well and there is 0 problems shown. Second hand device that I recieved yesterday. Going to contact Google tomorrow now!

1 Like

Actually, yes!

I’ve experienced this with my Google Pixel 2 plenty of times before, but I figured it was just a phone problem. I recommend just clearing the app cache, and that usually solves my problem for a little bit.

It eventually comes back, and I have to clear the cache again. I thought this was just me experiencing this. 😂

I hope for the best with your device anyways. Good luck. 👍

1 Like

Tried that as well!! Ive covered nearly every base I can think to try

1 Like

Same here. The game also freezes like this on me whenever I turn it into battery saver mode as well, and whenever I unplug the charger.

Very weird, Ill contact google and see If they come back with anything

1 Like

Well, this only happens with Infinite Flight for me, so I do not believe Google will solve anything in this situation. This might be a compatibility issue for the Pixel Devices, or maybe because Pixel Devices use Android Version 9.0+.

Maybe check this website out.

Have you found the if you begin the flight with the charger in and leave the charger in for the duration the device remains working?

1 Like

Yep, that is exactly what I do.

Quick search and it seems like a problem that exists on a few google phones on multiple games, IF, clash of clans etc. Definitely contacting google as I cant see it being a issue with all of these top ranking apps

1 Like

I will do the same. Google Support is always pretty reliable, so hopefully they can fix this issue as well.

Possibly try booting up into safe mood then rebooting to normal mode. This seems to have worked for some people but hasn’t worked for me. First time going from apple to android and its not starting well.

1 Like

Well, the Pixel phones are overall good phones, and I am glad (i’m google bias) that you made the switch.

I’ve had my Pixel 2 for a year and a half, and this is the only problem I’ve encountered.

Ok ive just managed to get round it, try, starting IF up as in battery save mode, go into a flight, before you plug the charger in remove battery save mode and then put on charge. Let me know if that works

1 Like

Well, it seems that the phone has to be idle for a bit, then you unplug and it freezes, as I just tried to unplug my charger while climbing, and it didn’t freeze. It might be because the operating system wasn’t expecting such a change that quick after being idle for so long.

1 Like

Im getting it if i plug in straight after take off, however Ive done two tests out of battery save mode and that seems to have fixed the problem. IF must be classed as a battery draining app and googles system for some reason interfears with IF causing the crash.

1 Like

Probably, (not 100% sure), but that sounds like a reasonable reason why it probably did that. I’ve sent in a feedback ticket to Google on this issue. I’m DM you, (or reply in this topic if it is still open) if I have gotten a response.