Google maps iframes (embedded) don't generate for new posts

Hi, I’ve used google maps embedded for a long time and it worked fine. However, today when I try to use them they did generate the space for it, but that was it, even with the maps that previously worked. For example, here’s the map from this post looks now:


Yep, just a blank white space. Is there any way to fix this? I’ve checked just pasting the Iframe into html and it worked, so I don’t think it’s an issue on google’s end
7 Likes

I’m on mobile so I can’t see it, but if you inspect this page and view the console are there any errors?

Definitely able to reproduce! I couldn’t embed a map for my VA thread

Hello Alexander,

To me it works in the post you gave us the link from.

Have you checked these:

Keep in mind only to use websites you trust, in iframes, as there is a potential security risk.

Reagards,

Ronny

That’s the problem: the one in the post but when I now try to embed the same map using that same link it doesn’t generate anything

I’ve checked it before posting. It’s not an issue on google’s end, as I was able to generate the map by just inserting the iframe code into the webpage


But for some reason discourse doesn’t generate the contents of the iframe properly, even though it identifies what it should generate correctly

For comparasion, here’s how the same bit of the same map looks if generated correctly

I hate tagging devs and staff, but from my observations it seems like @Cameron is the forum technical admin.

@Alexander_Nikitin,

I checked it on my macbook on safari and google browser, it works on both.
Nevertheless there are attributs which are not allowed or contradictory.
Try this, more simple:

"<iframe
width: “690”
height: “400”
frameborder: “0”
style=“border:0”
src=“https://www.google.com/maps/d/embed?mid=1aHP-GfTd4j7hjp5Bcy--Fghj_PXXqWI4” allowfullscreen>

"

it should work :)

cheers

User-posted iframes are disabled on the forum for obvious security reasons, so the system generates them by itself whenever it sees a link it knows the template for, like it is the case with, for example, youtube video links. The problem is not in the browser, but just in the fact that the code inside the iframe is not generating, as seen here.

Might want to check with whoever maintain the forums on the admin security settings of the IFC. If the google link is not enabled, it won’t show. I don’t think this is the issue, though, as this happened on another Discourse forum I’m a staff of even though the google link is already enabled.

I see you changed your topic(?)…indeed iframes are not allowed for new posts. Blocked for security issues.

Capture d’écran 2020-11-15 à 13.50.33

You could post a picture of your map and make it linkable ;)

iframes aren’t allowed, but they are allowed for selected sources like github, youtube and at least were for google mymaps. Of course posting a picture is an option, but it’s nothing compared to the past convenience of having it baked right into the post. Also yeah, I’ve changed the title for it to be more descriptive

the solution I gave is the best one for the moment (the best one I personally know), as iframes or any scripts aren’t allowed (anymore)…sorry for that…

I think you may be confusing iframes with what the poster types in vs the one that gets rendered. While the inspect tool is nice, some sites will auto generate things. For example, the map from the linked post is a url that goes to

https://www.google.com/maps/d/embed?mid=1aHP-GfTd4j7hjp5Bcy--Fghj_PXXqWI4

If I try that link I do get a blank square. We will check into this and let you know.

Disclaimer - being hosted and maintained by discourse we will often get updates to the platform which we may have little control over.

Hi Chris, thanks for replying.
I know by itself the google maps link in the post won’t do anything, but in the linked post discourse did generate a correct iframe for it just from the embed link, however for some reason it now generates empty iframes for the same links instead of generating a correct iframe. Haven’t been able to find something on it on discourse support forum, so this might be an IFC issue. Anyways, I would just wait for the solution for now because I don’t have access to the innerworkings of the site

Google iframe embeded maps once worked in the past on the forum but they do indeed no longer work. I don’t believe there is any solution without something behind the scenes being changed.

You can’t embed almost anything anymore.

1 Like