Global update isn't available

I’ve got still version 16.13.0 on my Samsung A5.

I’ve a feeling your device isn’t compatible. Give me a sec to check

Thank you for contacting support. Some Samsung users are unable to locate Infinite Flight in their App Store, which we have pinpointed to a device resolution issue.

  • Go to Settings > Display > Screen resolution
  • Increase your resolution to FHD (1920x1080)
  • Go to Setting > Apps > Google Play Store > Storage
  • Press “Clear Data”
  • Launch Google Play Store app
  • Search for “Infinite Flight”
  • App should now be available for download

Please let us know if you have any further issues. We appreciate your patience!

Just follow @schyllberg advice and ignore anything anyone else has said haha

5 Likes

That’s rude. Were just trying to help.

1 Like

It would be good to actually check device compability before ;)

1 Like

Happy to take this to PM.

Apologies if you think I was being rude though, I was merely pointing out that Schylly was here and handling it, and went in a different direction than both you and I saying it looks like the OPs device isn’t compatible.

He said it as a joke. But as said above, follow Seb’s advise.

If Schyllberg’s method doesn’t work, check your compatibility:
Does your device have at least Android 5.0?
Does it have OpenGL ES 3.0?

Uhhh, my device is compatible and Infinite Flight doesn’t show in Google play. Is this similar? Therefore, I have no access to Infinite Flight.

Just followed Seb’s advice but it didn’t work

Just because you have Android 5.0 and newer with OpenGL ES 3.0 doesn’t guarantee that your device is supported.

Android Requirements:

  • Android 5.0 (Lollipop) operating system or later
  • Device must support OpenGL ES 3.0 (Check here.)

Note: Due to large variety of Android devices there is not a specific list of supported devices. Customers with devices that are not supported at this time will receive a message on the Google PlayStore when attempting to download the latest update for Infinite Flight to advise that the device in use is not supported.

There are far too many Android based devices out on the market for FDS to test compatibility and operability.

What?!! But I was literally using global last week!!! But then again, Chris is right… Even though I do meet the requirements

If you were in fact able to update before…This has to be an error on the PlayStores end. Are you 100% certain that you followed the directions for the workaround?

I was able to play until the hotfix a couple weeks back. Also, I couldn’t change the resolution of my screen. I followed it all then there wasn’t an option for screen resolution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.