Global servers down?

Haven’t seen this is as a duplicate but I am trying to fly with a few friends and we are all having the same issue where we cannot get onto the Global Server.

Is anyone able to advise me?

9AF897BD-FD97-4C50-A8D4-968D79A3035B

6 Likes

I just restarted infinite flight and it was fine

I did the same thing and nothing happened

Restart your device, if that doesn’t work then uninstall the app

I am having the same problem as well…

I am same problems on solo

I’ve had the same issue a few minutes ago. Restart your app and you should be fine. :)

@Liam_purcell if you look at the brackground screen it shows now planes flying.

I’m doing that and nothing happens

Im having issues too. I think the servers are struggling… the training server is at 81% capacity.

guess it’s that weekend rush hour.

See if there is a update you have missed. I just updated IF

6% just disappeared

Having the problem too

I’m having the same problem, I tried closing the app, turning off and on the ipad and nothing happened.

2 Likes

There is also no update for IF right now. I have installed the latest update, yesterday’s bug fix, and it still doesn’t work…

6 Likes

Help I can’t get on, same problem

Apparently my account is being used on another account? Isn’t at all 😂

Relax everyone. Stand up, stretch, get a drink. They will fix it. It is not just you so no need for everyone to reply.

4 Likes

Maybe it’s me 😏

Just a question of luck, I get connected but I forgot to take a FPL

I got that too. Does anyone know why?