Global server problems

Hello everyone
I’m having trouble with global server. It keeps going red when I approach the airports causing the airport to not appear properly. I’ve had to quit flights due to this as the runway would not render. Is there anyway I could fix this problem

Thanks everyone 👍

Have you checked your internet? Have you checked how much space your device has?

1 Like

My device is a 64GB IPhone 8. I got it at Christmas so it should be grand

Internet wise I’ve bad internet but up until now it hasn’t been a problem

Might be the issue there. How much space in your phone is left?

Have you also tried clearing scenery cache?

1 Like

I’ve used 27.5GB

I clear cache after nearly every flight

Then it’s quite likely your internet acting up now.

1 Like

I’m hoping that it maybe fixes it itself if ya get what I mean but I’m seeing if there’s a better solution

That probably is it. My dads working from home so he needs the internet. But my latest flight he was off the WIFI so I don’t know about that one.

Have you tried classic ways of troubleshooting? Like using Airplane Mode for 30 seconds, turning off your router for 30 seconds, et cetera.


No I haven’t done airplane mode I’ll try that. The router thing won’t work though as the whole house needs WiFi and doubt they would be happy

You might as well ask them if you can switch it off and justify it by saying it’s not working on your phone.

1 Like

I could try that but can’t now as we’re using the Apple TV

Have you received any problems with your storage recently?

1 Like

No storage is grand

1 Like

Haven’t even used half

Yeah. Definitely looking at your storage space, 64Gigs is a lot. My device only has 16Gb which is why the airport scenery didn’t load on approach the last time, while the global server indicated red.

1 Like

Ye I’m hoping this is just temporary

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.