Global Server issues

Good evening everybody,

I’m not sure if i missed it or not but I’m having a lot of issues with the global Server lately.
It’s just the red exclamation point.

Runways and terrain won’t really load and it just looks like bland cardboard.

The take off went well and then everything else just went to… Well, you know.

Is there anything I can do?

I do clear my cache regularly and restart before every flight.

This was also a 13 hour long haul flight.

Thanks :)

Hey, do you have a stable connection or have you tried using a different connection source?

I have a stable connection and never had issues before and I’ve used IF for 5 years or so…

Not sure what’s happening

Apparently I was on the ground already… Who knew

Ah, I see. Have you tried uninstalling and reinstalling the game?

I have not and I’d like to have that as a last resort.

It only happens during long hauls

Yeah, that definitely should help as it will start your game fresh as new. I’d give it a try if nothing else has worked.

If this is an iOS device, maybe try going to storage settings and offloading the app to try and free up data to load scenery.

1 Like

It’s an old android. Maybe it’s time to replace it but it’d be still nice to know if there’s a possible fix for it.

Flying 13 hours and then having the scenery not load is just frustrating.
To add to all that: the logbook obviously shows an incomplete flight but it also only shows 11 hours flight time.

And if we’re being serious for just a minute let’s not forget that this app costs money and things like that are just not fun to experience.

Especially if there isn’t a solution

Hello!

Tap the red “Global server” icon. It should contain more information :)

Morning sir,

I did tap it but i honestly forgot what it says.
Since this is reoccurs quite frequently I’ll let you know next time this happens.

1 Like

How much storage do you have left in your device?

1 Like

Turn your ‘Airplane Count’ in the online settings down to medium or less until the airport loads then back up - works for me :)

Its happening to me just now and the additional information box just says ‘no additional information’


Can you recommend anything else?

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.