Global server issue ongoing?

Agreed - it would seem highly likely to be related to the earlier issue which was confirmed to be coming from the server provider, so not a fault on IF’s end.

Maybe, why don’t we all just relax, there’s obviously an issue, so maybe we should wait until a staff member or mod comment about the issue, to avoid speculation, and everything…


is there a chance the game will crash?

Seeing from last time it’s probably a 50/50

Yes there are still chances your game might crash, and this issue is not related to the crashes. The crashes have been an ongoing issue since the release of 19.4 if you’re using an iOS device.

1 Like

Hello, I know that they have put notifications, that they are looking for the problem, but every day this is worse, today I have tried to enter and in 5 airports it has given me the same result, loading your Flight. It is frustrating waiting more than 10 minutes and not getting any kind of access. yesterday I was able to fly without any problem, today I even uninstalled the application and still did not get a satisfactory answer.
I just hope this problem is solved quickly,With this message I am not looking for a solution or attention, it is only an expression of what I feel when trying to fly and fly through the skies. Again.

Iam flying right now so… I hope my game dont crash :/


I mean by the global server problem, if the game could crash

Ok, so I’ve just exited the flight (and app) and gone back in, and can confirm it won’t load a flight up. Stuck on the following screen.

1 Like

I’m flying from Johannesburg to Amsterdam so as long as it is resolved in the next 7 hours I’ll be happy haha

Just a question, are both iOS and android experiencing this or is it on one separate provider?

1 Like

Users of both appear to be reporting the issue.


Both, iam playing on android

Ladies and Gentlemen, Marc (Edit: And DeerCrusher) are here to help!


Thank you for the reports everyone. We had some issues yesterday, this might be just an after effect. Staff was made aware of this. Please report if it’s working again and if you have problems here in this topic.

No off-topic chatter please.


It seems to be half and half having the issue. I don’t have the issue but obviously do.

I’m in the middle of ICN-ATL and my ETE to DEST has not moved. Anyone else having this issue on top of the rest?

Currently on a 10 hour flight so I hope it doesn’t crash but I can confirm the global server still isn’t loading

1 Like

Its on me too, keep flashing around from green to red. I took yesterday 22:30 GMT+2 European time and its still flashing now! Plz Fix it. 😔 😿

Right now my global server turned green