Global Server Connection Glitch and Crash


I looked through support and didn’t see this issue reported, so here it is.

During the past four flights I’ve attempted to fly, the app has crashed, usually either during takeoff or during cruise. I’ve noticed that before this happens, the phone disconnects from the global server, indicating a red ! icon on the top right corner. I’ve tried connecting to other wifi networks and using LTE but this hasn’t fixed anything. It’s currently limiting me to short haul flights, and even then, those can crash sometimes.

Device: iPhone 11 (this is a different phone than in earlier support posts by me, and was running IF flawlessly before the update)
Operating system: IOS 16.1.1



What server is this on?

Expert server, happened when departing Istanbul, Erbil, and Los Angeles if that matters

Do you have enough RAM on the device? Less RAM can lead to more frequent crashing.

I’ve only had this phone for about a month, so it has plently of ram

I suspect it’s either a RAM issue or a Wi-Fi issue. I’ll see if I can help you later. For now, has IF crashed on your older device too?

and besides, the first time it crashed was seven minutes into the flight, and the second time was 1:20 into the flight. If it was a storage issue (which I’ve experienced on my older phone), it would crash at the same duration into the flight.

I’ve also checked the wifi router and everything seems normal, it also crashes on other wifi networks

I found this comment which might be able to help you.

I really don’t think it’s a device peformance problem, it was running sixteen hour flights from Los Angeles to Singapore perfectly before, and I have all graphics on low, anti-aliasing off, and set 30fpm max. The only app I keep in the background is IFOperations.

Other than device problems, I think it’s something related to 22.8 (not sure tho).

Yeah, I’ve only done 11 flights on this phone and the settings I have for this phone worked well on my older phone.

It did it 4x on me also. Is there a server issue going on?

How much storage do you have available on the device?

Around 2GB

Also happened to me on my iPad Air 2022 (5th generation). No issues with storage or anything but the global server was flickering between red and green and then the app crashed 5-10 mins after takeoff

1 Like

Can I pls get an update on this? I’ve tried freeing up some storage and it’s still crashing :(

Also happening to me. Getting major expert server interruptions followed by crash. Galaxy A7 tablet and on my Galaxy S9+

It has happened to me at least twice a day since I got it updated.

1 Like

Happened to me as well about 2 hours ago taking off from KSEA in a 175, passing through 16000 feet.