Getting denied on the training server?

I was in the middle of a flight from Toronto to Ottawa when I was about to land, then I got this:

As you can see, 0 reports, but I got disconnected
I was disconnected once, then it tried to connect then if gave me that message


The problem has been solved, thank you Tyler!

1 Like

Same here just happened to me as well

1 Like

The server (TS1) went down. It is back up now


It happened to me too

1 Like

Yh it just happened to me 2

Does anyone know why i had zero reports also

If it’s back up, does that mean I need to quit my flight and reconnect? Or will it reconnect for me?

I still have the red exclamation next to the ‘live server’ icon in the top right corner.

1 Like


Me too. My account IFSFG217-Art, please help us.

It should just connect itself. If it doesn’t, then you would just have to restart

Servers just went down everyone, no need to panic.

As @Balloonchaser said above, they work perfectly fine now. 😉


I recommended that too, didn’t work for me. Hopefully it helps some one else!

Yep same thing is happening to me. Good to know that it’s not just me, but hopefully they’ll get it fixed soon

1 Like

Hang tight everyone, FDS is aware and looking into it.


Thank you for contacting support! We did recognize an error in our grade system/server requirement setting, as the training server does require Grade 2 to gain access. We’ve made the appropriate change to reflect this.

Casual: Grade 1
Training: Grade 2
Expert: Grade 3

We do apologize for any inconvenience and appreciate your understanding!



Thx. Good to know…