Game not loading

Hello, my game is unable to load since this morning (I m from India). First, the game would start but as soon as I click the fly button, it would just keep loading. If I then press back or try to close the game then all of the UI like autopilot controls, thrust etc. would appear but with the loading screen still on. After I reinstalled the app, the game would not even start. It keeps showing failed to download navigation database check your internet connection.

My connection works fine (4g) both on cellular network and wifi, I checked it with other apps.
I tried everything I could like choosing a different aircraft, a different airport when the app was opening.
I restarted my device, restarted my internet connection, restarted the app, reinstalled the app.

Hey there!

Can you confirm that this doesn’t happen at all airports/aircraft? Can you give examples of airports and aircraft that when picked don’t work?

It could be that specific aircraft haven’t been downloaded yet. If so, can you please check the amount of available storage you have on your device?

Now I can’t confirm for all airports because the game would not load at all. I tried the airbus 350 and 320. I tried mmmx and skbo. The avianca livery wouldn’t load. I even tried aer lingus on the 350.

My device is oneplus7T 128gb storage if it is any help

Available storage or total storage?

Total storage… 60 gb is available

1 Like

I see. When you press “fly” does the screen go black or do you still have the loading screen? Do you perhaps have any screenshots when this happens?

I have the loading screen. Pls wait I’ll get a screenshot. Thank you :)


I am sorry, I just realized I cant get into the app so can’t get a ss now. My bad.

1 Like

This is the only thing I am getting now

Oh, so it’s an issue with the new navigational update. Can you check that you’re on a good internet connection? (Not cellular)

I know you’ve already reinstalled, but could you try again?

1 Like

Sure I will give it a try. I also checked on my WiFi network and it also has a good speed. I’ll try again and get back here. Thank you so much for taking your time to help :)

1 Like

There have been issues like this before when on cellular. IF use a content delivery network for scenery and in game content. And if your service provider has issues towards them this could happen.

So as BC said, try WIFI 🙂


So, I tried the app and it worked. The aircrafts were available but the map wasn’t showing this time. If I searched for an airport it would just show the airport but not where its runways are or the gates. Anyway I clicked fly and the same happened. Then, i reinstalled the app and restarted my device and again it showed error while downloading database as shown in the ss above. I did all of it on my WiFi.

I took a ss of the loading screen.

I’ve taken a look at some issues like this and the solution is to restart your app and device once more. I know you’ve done it before but since you’ve done different steps the restart could be depandent on the issue.

1 Like

I will try it again. And if it still doesn’t help, any suggestion what to do after that😅.

If that doesn’t work, try the following:

Delete Infinite Flight —> totally turn off device —> power it back up —> reinstall Infinite Flight

1 Like

Tried it. Unfortunately, it is the same story.

I’m sorry, I’ve completely ran out of ideas. I think your best bet is to wait for schyllberg to assist you.

Is there anyway I could contact him or I would have to wait until he sees this

He will see this, just give it some time :) You could contact him if you want but he’ll see it either way.