Game freezing as I'm using ATC

I saw a recent post by someone mentioned their game was crashing as they were controlling.

For me it’s when I’m using ATC, IF completely freezes, now I’ve tried logging out and clearing all apps.

The game is fine and working fine until I press ATC to taxi.


Also note in both of these images that the METAR is really wonky.

Running on the S8 latest update, highest graphic settings as usual.
Its not a performance issue, as I said previously the game works fine until I try to use ATC

Hello!

I am using the Galaxy S8 too and I have never experienced this issue.

Have you tried reinstalling the app?

Could you try it at KBED? Attempt to contact ATC.

Here is a video, https://youtu.be/lfnZo_1LMb0

1 Like

I did what you’ve said but my game didn’t freeze completely but for a bit definitely, also METAR issue.

1 Like

I am currently trying to use Infinite Flight and experiencing the same issue with my game freezing when using the atc menu. I tried restarting my device, and re-installing the app and nothing seems to help.

2 Likes

This sounds more like a server issue.

Weather api has been messed up all day

1 Like

This just happened to me and my game is frozen as well!

2 Likes

It happened to me too, the app freezes for a couple of seconds after trying to use ATC. And this happens everytime I try to use ATC.

2 Likes

I’ve just found out that the issue is not with an airport. I spawned in LFPG and the same thing happened

image

I’m using iPhone X. Latest versions of everything. Have a lot of memory free and no apps running in the background

4 Likes

Yes, not an airport related issue, it is occurring to me in Moscow (SVO).

1 Like

I guess we just wont use ATC for a while…

Just kidding… that would be dangerous.

All jokes aside hopefully it’s fixed soon 👍🏻👍🏻

I just tried out multiple airports, it happened to me at every single airport.

Let’s wait for a developer or a moderator to give us more information.

2 Likes

Be patient, looking into it.

Can you try again and see if it is any better?

Which server?

Seems to be working now. Just tried out every server and it didn’t freeze anymore.

Its happening to me too on the expert server!

1 Like

I’m having the same issue on an iPad Mini 2.

1 Like

Seems to be resolved for me, working fine now.

Everything is working perfectly but METAR:)

1 Like

Great. Metar could be the weather service having issues.

2 Likes