Game crash and lag

this one but I most likely need to turn down the airplane count

You would be correct.

Correct again.

Turn on limit frame rate, or lower your graphics settings. Over time updates require more processing power from your device so naturally your device’s performance starts to diminish. So, it’ll be permanent and it will gradually get worse.

That’s unfortunate 😔


Ok @Tate_Wang

Indeed it is. We all face the same problem and shell out a few hundred dollars every few years for a new device to stay up to date, and it’ll be like that for the foreseeable future.

If you need any more help, feel free to shoot me a PM!


Game crashed again when I was on approach to São Paulo, and there was no lag

What kind of device are being used and which graphics settings?

An iPad (I don’t know what version yet) and I had medium airplane count. I’ll take a screenshot

Can you try to identify the iPad model? The airplane count is one thing, the graphics settings is another that have even more importance :)

Here are the pictures and my iPad is just an iPad not an iPad Air, not a iPad Pro just and iPad

That may be true , but Jason’s blog just mentioned improvements to overall game performance with 20.3 and also with 20.1 , so is the game running smoother or getting worse with each upgrade ? Can’t be both
right ? Hey Jason clarify when you have a minute
thanks Personally, yesterday I experienced significant lag or stutter , today not, same server region device performance etc.

Well, a device naturally diminishes in performance but changes can be made for efficiency and optimization which can improve performance.

@schyllberg are you still here?

If I am not mistaken, if you click on the button “About”, then in the top left, it will show your iPad model, so we will know what your iPad is.

In the settings app?

1 Like

In the settings app, yes.

1 Like

It’s an iPad 6th generation

1 Like

Since the iPad 6th generation is two and half years old now, you need to slow all the Graphics quality at “Medium - Low”.

That’s frustrating 😤

1 Like