Friend is having trouble...

Ever since the newest update, my friend, Jack Fiddy has has trouble flying planes. Every time he tries to fly something like the 737 or the a340, he can’t control the plane. He reaches around 200 kts before over shooting the runway and still he can’t pull up. If he does manage to rotate, then he pitches up slowly and stalls and crashes… anybody know Why?

Does he calibrate his phone/screen before flying?

Has he checked the weight and balance? He could be over MTOW in some cases, they cant take off and drop speed dramatically after that.

He should look at the sensitivity (in game settings), device calibration (he needs to recalibrate before beginning the flight by holding the device in the normal position as if he was flying, and hitting the calibrate button on the menu page), and trim (there are tutorials here on the IFC for that)

Yes. He does every thing to change it.

Has he already tried restarting his device or reinstalling the app?

Not yet but I’ll tell him to when he gets back…

Tell Jack to create an account and create a topic with pictures and videos.


What I suggest is go to settings>controls, and then your friend can test his/her controls from there.

In the settings, your friend can also check the sensitivity and adjust it according to his/her needs.

After readjusting the settings, do a quick test flight on solo or casual server to avoid violations.

Always make sure you do a flight control test too make sure there free and correct before takeoff.

Is your friend using flaps? Has he ensured both engines are on? Has he checked spoilers aren’t active? Has he made sure the brakes not on aswell?

To summarize a couple of the ideas, and adding some:

  • Check that the device rotation lock is off
  • If it’s an Apple device, open the compass app and check if the gyroscope actually works
  • Check your control settings in IF. May be the sensitivity is to low
  • Spoilers need to be deactivated
  • Flaps need to be set correctly
  • Takeoff only below MTOW
  • Brakes need to be deactivated
  • Calibrate device before takeoff
  • Calibrate device before takeoff
  • Do a flight controll check before takeoff

Don’t worry anymore guys, jack restarted his phone and it somehow works now… now someone can close the topic. Thanks for all the suggestions guys :) :)

1 Like