Frequencies not shown

Hey everyone,

I created this topic because this issue has started to repeat more and more often for me lately.

In the recent days I often times was unable to see frequencies on airports, such as ground. I do check the current active services via LiveFlight and even get commanded to tune out and switch to certain frequencies, however they are not showing up in any menu.

The problem is that I dont want to put myself into a risk of a ghost as I literally cannot follow the instruction and therefore am forced to divert or quit a flight.

This is not a brand new issue, it was a topic a couple years ago, but since it happened to me too often recently Im concerned and would ask for the following:

  • What can I do in such a situation
  • is it fixable individually
  • do others face the same sort of problem

Thanks for any helpful tipps, hopefully we can find a solution to this.

(Device Info: I Pad Pro 2019 12inch. IOS 12.3.1 with massive amount if storage left)

A common tip is to turn on airplane mode for about 30 seconds, and then reconnecting to the server. It’s worked every time that I’ve tried it, so maybe you’ll have some luck with it as well.

2 Likes

thank u, I will try that out next time and share if it worked

1 Like

I’ve been having the same issue more frequently since the update to 19.4, but fortunately @TaipeiGuru’s solution has worked every time for me

I’d add that it never hurts to reach out to the controller on here when you realize this is happening to give them a heads up

2 Likes

yeah but that is almost never an option since the time is extremely limited. When Im instructed to go from Tower to Ground it has to happen fast not to block the approach flow. Responses from the controllers sometimes come in way after the session :/

Yeah there are definitely limits to how helpful it is, especially in a rapid handoff situation like Tower to Ground. I personally haven’t seen that happen, and would always recommend checking all frequencies before tuning in to one if you haven’t already been doing that.

1 Like

If this happens put your callsign as “NORDO” to let the ATC know that you are unable to establish radar contact with them.

1 Like

never heard of this before! Thank u very much

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.