FPS drop and Crash

So I spawned in at EHAM, filed my flight plan from VirtualHub, loaded fuel and set AP and other pre taxi procedures. Then when igniting the engines and almost immediately after I start taxiing the game drops from a 45-60fps to 3-4fps. And from a stable 20ms to 250-300ms. At this point the game is unplayable and I have to exit my flight. I tried restarting app and device by the problem remains. I did some testing and when I just started taxiing immediately after I spawned in I just recieve the “crashed” screen as if I whould’ve crashed.

I’m using the latest version of IF and the iPad Air.

What view were you in?

I suggest rebooting and/or reinstalling.

Camera view? Cockpit and freecam. Will try reinstalling the app.

Make sure you are not excessively moving the camera around. Excessively moving the camera around causes less and less frame rate.

Also, can you ensure you have a strong Internet Connection?

I was using cellular 4G data. So I don’t think my connection was the issue. I’ve used that before with no problem.

1 Like

Have you tried reinstalling yet? If so, any change?

Otherwise, how much free storage do you have?


I was having the same issue after the most recent iOS update, a factory reset fixed it for me. (Reinstalling the app didn’t fix)

I was playing in iOS11.3Beta1 then I realize somehow start lagging…
I downgrade rapidly to iOS11.2.5 :D don’t wanna risk (iPAD2017)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.